Bug 138854 - prints postscript as text on dot matrix printer
Summary: prints postscript as text on dot matrix printer
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-printer   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL: http://bugzilla.redhat.com/bugzilla/s...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 17:01 UTC by pj
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 17:08:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pj 2004-11-11 17:01:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
FC2 system-config-printer and/or system-config-printer-gui has a bug
when selecting "text only" printers. It will still put a postcript
.ppd file in /etc/cups/ppd/ and try to print P.S. to the text only
printer. "Raw Print" is not acceptable since I can NOT add form feed.
There is an open bug on the RHEL side noted as fixed...

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=124250


Please port the correction over to FC2. 

PS problem exists as of:
system-config-printer-0.6.116-2.i386.rpm
system-config-printer-gui-0.6.116-2.i386.rpm
fully updated otherwise as of 10 minutes ago.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116-2.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Setup text only printer in gui to print to a text/line printer
2. try to print text test page
3. junk comes out
4. look at the .ppd file in /etc/cups/ppd/ It will be postscript.

Actual Results:  prints PostScript

Expected Results:  Prints text

Additional info:

Comment 1 pj 2004-11-11 17:05:33 UTC
Correction: I was trying to upgrade to the noted system-config-printer
versions above. The updated FC2 version that is installed on my system is:

system-config-printer-0.6.98-1
system-config-printer-gui-0.6.98-1

Comment 2 Tim Waugh 2004-11-11 17:08:41 UTC
This is fixed in FC3.

Comment 3 pj 2004-11-11 17:25:20 UTC
I gues bugs aren't being fixed in FC2 now :(

the system-config-printer-0.6.116-1 and
system-config-printer-gui-0.6.116-1 packages build from FC3 source on
FC2 mostly work. The gui can not seem to edit any entries. It can
create however. The TUI version can edit, however.



Note You need to log in before you can comment on or make changes to this bug.