Bug 138859 - FC3 Kernel hang on Tyan S2881 motherboard
FC3 Kernel hang on Tyan S2881 motherboard
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 12:24 EST by Ladar Levison
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 16:49:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ladar Levison 2004-11-11 12:24:03 EST
I was able to install FC3 by using noacpi and mem=128m, but now the
kernel won't boot.

The UP and SMP kernels hang in different spots.

My system configuration is : 

Tyan S2881
Dual Opteron 246
4 x 1G KVR (Reg)
Adaptec 2120S Raid Card
6x SCSI Seagate 146G Drives.

Version-Release number of selected component (if applicable):

Stock FC3 Kernel.

How reproducible:

Everytime.

Steps to Reproduce:
1. Turn machine on.
2. Turn machine off.
3. Turn machine on.
4. Goto step 1.
  
Actual results:

System hangs while scanning PCI bus in UP mode, and right after
detecting the processors in SMP mode.

SMP hang point :

CPU: L1 I Cache: 64K (64 bytes/line)...
CPU: L2 Cache: 1024K (64 bytesl/line)
System hang...

UP hang point :

PCI: Probing PCI hardware (bus 00)
System hang...

Expected results:

Sytem to boot...

Additional info:

I am single and I like long sunset walks on the beach...
Comment 1 Holger Eilhard 2004-11-15 06:20:15 EST
I remember issues with Tyan boards an Adaptec Raid Controllers. Do you
have the latest Bios?
Comment 2 Ladar Levison 2004-11-18 17:15:59 EST
I changed out the RAID card for an LSI Megaraid, and everything
appears to be working.

One side note, when experimenting with this configuration, I
originally booted with 'linux mem=128m text', at which point
everything appeared to work. However, once the drives had finished
formating, the screen displayed a kernel panic, before copying the
install image.

I tried a second time, and got the same result. On the third boot, I
used no options, and went through the graphical installer. However, I
elected not to format the existing partitions. 

Now everything works like a champ. I am looking forward to
benchmarking this puppy.
Comment 3 Dave Jones 2005-07-15 16:40:56 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Ladar Levison 2005-07-15 16:49:08 EDT
I have since switched to using a Tyan S2882 motherboard, with Red Hat Enterprise
4. I've seen no problems. Current uptime stands at 109 days using the stock
kernel. I also presently use an LSI RAID controller, and not the original
Adaptec one.

Note You need to log in before you can comment on or make changes to this bug.