Bug 138861 - firefox-kmail interaction problems
firefox-kmail interaction problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 12:32 EST by Sammy
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 05:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-11-11 12:32:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; en_US) (KHTML, like Gecko)

Description of problem:
I have two problems when I click onto URL's contained in a mail message:

1. While mozilla and konqueror open the html location directly, firefox opens
    the html file copied to /var/tmp/kde-cache/krun/....
    The result of this is that any referred images in the html file does not
    show up since they are not in the tmp directory.

2.  When I click on a login reference to a NY Times article I get the login
    page. With firefox if you type your username and password and click
    login you get a message saying /auth/login cannot be found and login
    fails (you can login directly from firefox), however, when mozilla or
    konqueror are the default browsers they work just fine.

Version-Release number of selected component (if applicable):
firefox-1.0-1

How reproducible:
Always

Steps to Reproduce:
1. Make firefox default browser (under kde, don't know about gnome)
2. Strart kmail and click on a url contained in a mail message
3. Should be tested with mozilla mail or thunderbird too.
    

Additional info:
Comment 1 Sammy 2004-11-11 12:48:12 EST
SOLUTION! 

If one puts "firefox %u" instead of "firefox" into

/usr/share/applications/mozilla-firefox.desktop

than kde knows the url and firefox opens at the location instead
of using the cached file. The second problem seems to go away too.

One little problem with this is that if you already have a firefox
running after clicking on the link the new page opens but the little
firefox icon keeps blinking for about 30 seconds. If there is no
other firefox open this does not happen.

FYI
Comment 2 Sammy 2004-11-15 15:39:06 EST
Is it  possible to add the %u to the desktop file for the next release 
so that I don't have to change it by hand? It effects all embedded links 
under KDE with firefox. 
Comment 3 Sammy 2004-12-12 16:10:36 EST
Just a reminder that the mozilla-firefox.desktop needs %u for firefox 
to work with links in documents and e-mail. 
Thanks 
Comment 4 Sammy 2004-12-17 08:38:59 EST
Any particular reason why this small change is not making it into new 
updates? It is a pain to go make this change on many machines everytime 
firefox is updated. 
Comment 5 Warren Togami 2005-05-16 05:40:12 EDT
Fixed in FC3, FC4 and RHEL4.

Note You need to log in before you can comment on or make changes to this bug.