Bug 1388637 - glibc: nss_db: long group entries are skipped
Summary: glibc: nss_db: long group entries are skipped
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glibc
Version: 7.2
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Carlos O'Donell
QA Contact: Michael Petlan
URL:
Whiteboard:
Depends On: 1318890
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-25 19:36 UTC by Marcel Kolaja
Modified: 2020-02-14 18:03 UTC (History)
11 users (show)

Fixed In Version: glibc-2.17-157.el7_3.1
Doc Type: Bug Fix
Doc Text:
The nss_db module failed to request larger result buffers when parsing groupentries. As a consequence, group entries with a size in a specific range wereskipped. With this update, nss_db detects when a group list does not fit intothe result buffer and requests a larger buffer. As a result, group entries inthe affected size range are processed correctly.
Clone Of: 1318890
Environment:
Last Closed: 2016-12-06 17:05:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2861 0 normal SHIPPED_LIVE glibc bug fix update 2016-12-06 22:00:44 UTC
Sourceware 19837 0 None None None 2016-10-25 19:36:33 UTC

Description Marcel Kolaja 2016-10-25 19:36:24 UTC
This bug has been copied from bug #1318890 and has been proposed
to be backported to 7.3 z-stream (EUS).

Comment 5 Michael Petlan 2016-11-08 19:01:10 UTC
Reproduced with: glibc-2.17-157.el7
Verified with:   glibc-2.17-157.el7_3.1

VERIFIED.

Comment 7 errata-xmlrpc 2016-12-06 17:05:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2861.html


Note You need to log in before you can comment on or make changes to this bug.