Bug 1388651 - gfal2-2.12.2-2.el7.aarch64 not instalable
Summary: gfal2-2.12.2-2.el7.aarch64 not instalable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gfal2
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adrien Devresse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-25 20:31 UTC by Mattias Ellert
Modified: 2016-10-28 06:48 UTC (History)
3 users (show)

Fixed In Version: gfal2-2.12.2-2.el7.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-28 06:48:40 UTC


Attachments (Terms of Use)

Description Mattias Ellert 2016-10-25 20:31:06 UTC
Description of problem:

Building a package that depends on gfal2 in koji for EPEL 7 fails:

DEBUG util.py:421:  Error: Package: gfal2-2.12.2-2.el7.aarch64 (build)
DEBUG util.py:421:             Requires: libpugixml.so.1.0()(64bit)
DEBUG util.py:421:   You could try using --skip-broken to work around the problem
DEBUG util.py:421:   You could try running: rpm -Va --nofiles --nodigest
DEBUG util.py:557:  Child return code was: 1

Version-Release number of selected component (if applicable):

gfal2-2.12.2-2.el7.aarch64

How reproducible:

Always

Steps to Reproduce:
1. See above

Actual results:

Package uninstalable due to broken deps

Expected results:

Package installed

Additional info:

The dependencies are inconsistent:

gfal2-2.12.2-2.el7.aarch64.rpm depends on libpugixml.so.1.0()(64bit)
gfal2-2.12.2-2.el7.ppc64.rpm depends on libpugixml.so.1()(64bit)
gfal2-2.12.2-2.el7.ppc64le.rpm depends on libpugixml.so.1()(64bit)
gfal2-2.12.2-2.el7.x86_64.rpm depends on libpugixml.so.1()(64bit)

Note the different soname on aarch64.

However,

pugixml-1.7-3.el7.aarch64.rpm
pugixml-1.7-3.el7.ppc64.rpm
pugixml-1.7-3.el7.ppc64le.rpm
pugixml-1.7-3.el7.x86_64.rpm

all consistently provides libpugixml.so.1()(64bit)

Which means that the gfal2 package on EPEL 7 aarch64 is not installable.

Comment 1 Richard Shaw 2016-10-26 13:02:00 UTC
I just submitted a bodhi update after a simple rebuild that seems to have fixed the problem. I lowered the karma requirement to 1 so once it hits testing and you give it +1 it will go to stable without having to wait the usual 2 weeks.

Comment 2 Fedora Update System 2016-10-27 06:49:33 UTC
gfal2-2.12.2-2.el7.1 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd5601774a

Comment 3 Fedora Update System 2016-10-28 06:48:40 UTC
gfal2-2.12.2-2.el7.1 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.