Bug 138866 - Fedora core disk geometry in dual boot with WinXP
Fedora core disk geometry in dual boot with WinXP
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 13:02 EST by Martin Ng
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ghost-broken-table.img (512 bytes, application/octet-stream)
2005-01-08 05:40 EST, Remi COLLET
no flags Details

  None (edit)
Description Martin Ng 2004-11-11 13:02:41 EST
Description of problem:
Installed Windows XP on hda0 and Fedora Core 3 on hda5.

Both were able to boot after the FC3 installation. 

Problem 1: Upon checking with partition magic in WinXP, am told that 
LBA and CHS values differ and attempts to fix it. If you fix it, 
Partition magic will inform you that there are 2 sets of disk 
geometry and you should backup and recreate all partitions.

Problem 2: Unable to make and image of FC3 with Norton Ghost either. 
Ghost halts with this error:
Application Error 2004 
Read sector failure 
result=1, drive=0 
sectors 2091227287 to 2091227295 

Used fedora rescue disk to check CHS value:
fdisk -l /dev/hda to find out CHS is 3876,240,63 
Reinstalled FC3 at boot entered linux hda=3876,240,63 
Same 2 problems occured as above.

Tried to remedy the partition table:
sfdisk -d /dev/hda | sfdisk --no-reread -H255 /dev/hda 
But the same 2 problems as above occur.
Also tried setting -H240 with the same results.

Bios does not have an option to use LBA only.

Note however aside from the disk geometry problems both OS can boot 
and no data loss is apparent.

Seems that the fedora installer is not able to install at the 
specified linux hda=3876,240,63 


Version-Release number of selected component (if applicable): Fedora 
Core 3


How reproducible:
Always

Steps to Reproduce:
1. Install Windows XP on hda0
2. Install Fedora Core on hda5 using either partition magic or disk 
driud to make the partitions.
3. After installation, checking partion table using sfdisk, partion 
magic and there will be discrepancies.
  
Actual results:
Both OS will be able to boot but the partion table seems to indicate 
that diff disk geometries were used.

Expected results:
FC3 should not change the disk geometry. It should either covert CHS 
to LBA automatically or accept correctly input values of hda.


Additional info:
Comment 1 John Cooper 2004-11-12 07:49:48 EST
My installation of FC3 after XP installation rendered XP unbootable. 
Even the XP recovery disk just hung. This is as per 115980 FC2. I 
will try to pass hda=x,y,z arguments at boot cd and during FC3 
installation grub part to try to resolve this problem. Such a minor 
bug is causing huge grief and will put users off Linux.
Comment 2 André Mondri 2004-11-12 09:15:44 EST
It is incredible - SUSE, MDK and others had fixed it in the Week were 
this Bug was found. Now it is the 3´rd Release and it still happens.
Comment 3 Yaw Anokwa 2004-11-14 15:23:00 EST
Same problem here as Martin described. The only difference is that I
have WinXP on a SATA drive and FC3 on in ATA drive connected through
the PCI bus.

Would creating the Linux partitions on my drive with Partition Magic
before installing FC3 solve this problem temporarily?
Comment 4 Arno Waschk 2004-11-14 17:13:01 EST
what is the actual policy behind fedora people not mentioning this 
severe bug to innocent downloaders of FC3?
Comment 5 Jeremy Katz 2004-11-15 10:57:09 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 6 Martin Ng 2004-11-17 00:16:14 EST
I have tried partitioning with Partition Magic first but the same 
problem arises. Should be the FC3 installer overwrites it.

martx
Comment 7 Martin Ng 2004-11-17 00:32:21 EST
I have tried passing comments to grub installation in anaconda.
Same thing happens. 

Although this bug has been marked as a duplicate, i think the 
circumstances are different. For one, both FC3 and WinXp can install 
and seem to run fine, unless you check the disk geometry and sectors.

martx
Comment 8 George Kakos 2004-11-28 19:27:05 EST
I have the exact same problem! Why doesn anyonye really care anyway?
Comment 9 Yaw Anokwa 2004-11-30 11:00:25 EST
I still care, but like you, I have run out of ideas. I can't use FC
until it's fixed so all we can do is wait.

Martx: I know you've tried Partition Magic...but have you tried
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138419#c75
Comment 10 Martin Ng 2004-11-30 12:32:15 EST
I still care too...and i have run out of ideas too..

Yaw, i have tried that suggestion to use knoppix cfdisk to write to 
the partition table. Same thing happens after installation FC3, both 
windows and FC3 work fine. But when i try to image it ghost detect 
many overlapping sectors.

I guess the last option would be to make my windows partition smaller 
than 1023 cyclinders in size. (for me that is 7560 MB)
Comment 11 Martin Ng 2004-12-01 02:13:35 EST
Okie i have tried making my windows partition smaller than 1023 
cylinders and still no go.
Comment 12 Martin Ng 2004-12-01 02:15:02 EST
I tried installing a minimal FC2 since i know it works and could make 
an image. Then i upgraded to FC3 and the same problem arises.
Comment 13 Martin Ng 2004-12-01 06:03:30 EST
Tried force lba32 in advanced grub menu and it dont work either.
Comment 14 George Kakos 2004-12-06 19:10:40 EST
I am having he exact same problem here ! Safe and easy backup making
is vital to all of us!

Anyone came up with a solution?

PS I have managed to make a complete backup of my system using norton
ghost 9 but ghost 9  saw my fc3 partition as full (which actually
isn't). I haven't restored it to verify . Also sense norton thinks my
partition is full the image is way to big

Please someone help us!
Comment 15 Yaw Anokwa 2004-12-07 22:00:39 EST
Martin: Have you tried using
http://people.redhat.com/~katzj/fc3-part-upd.img

You can find instructions here at
http://rhlinux.redhat.com/anaconda/updatedisks.html
Comment 16 George Kakos 2004-12-09 18:22:31 EST
I am trying it now and i'll post results soon
Comment 17 George Kakos 2004-12-09 19:01:49 EST
Well actually i inserted my fedora core 3 dvd , typed linux updates @
start , choose fd0 (my floppy) to update , anaconda read the update
info and then it started the usual installation procedure and i had
either to install a fresh fc3 installation or upgrade the existing. Of
course i am not interessted @ destroying my existing fc3 installation
so #1 is not an option. So i should choose to upgrade my existing
installation? Won't this procedure actually downgrade all of my
updated components ( kernel etc etc ) which i updated through fedora's
up2date?
What should i do anyway?
Comment 18 Remi COLLET 2004-12-18 05:55:51 EST
We have the same problem : ghost is unable to dump FC3 partitions.

I've try the update from Comment # 15. Did not work at all (grub is
broken).

Try to install FC3 alone (no dual boot) : same problem.

Try to install from FC2 partition (no format) : same problem.
Comment 19 Rubens Mau 2004-12-25 09:16:27 EST
I ask to reopen this ticket , the fact that ghost does now backup
fedora partitions anymore is very annoying.
Comment 20 Andrew Clausen 2004-12-25 16:05:53 EST
This bug was closed because it is a duplicate of bug 138419.
That bug has also been closed, because the bug has been fixed.

If there are still problems with the latest updates, then please let
us know.
Comment 21 Martin Ng 2004-12-27 21:55:08 EST
I feel that this bug is different from 138419. In that bug, the 
installer does not work and even if it does either windows or fedora 
does not boot.

In 138866 however, both OSes can boot. It is when we try to make a 
backup image using norton ghost that reveals the partitions are 
messed up.

I do hope this problem is looked into again too.
Comment 22 Rubens Mau 2005-01-07 13:23:23 EST
I don't understand what happens with this bug - if it is important for
so many people to backup using Ghost, why there is no feedback from
the developers ?
Comment 23 Andrew Clausen 2005-01-07 18:05:02 EST
To my knowledge, this bug has been fixed.  If I'm wrong, then give me
evidence!  Also, it would be helpful to attach the first part of your
partition tables.  You can do this with:

      dd if=/dev/hda of=ghost-broken-table.img bs=512 count=1

Martin: the symptoms are different, but the root causes between the
bugs are the same.  Fedora's installer (which uses libparted) was
modifying the CHS start/end values of partitions.  This does not
usually hurt Windows dual boot... it is only due to a bug in the
Windows installer that some OEM installations have this problem.

That would explain why you don't have dual boot problems in addition
to Ghost problems.
Comment 24 Remi COLLET 2005-01-08 05:40:02 EST
Created attachment 109511 [details]
ghost-broken-table.img
Comment 25 Remi COLLET 2005-01-08 05:42:24 EST
I also think this bug is not fix (for ghost).

I'm used to install dual-boot (win2000+FC2) using ghost without any
problem.

On one of this PC i have :
- corrected the partition table (there is some errors)
sfdisk -d /dev/hda | sfdisk --noreread -H 255 /dev/sda

- install FC3 using the fc3-part-upd.img

After this, dual-boot works fine for the 2 OS, but ghost still unable
to dump the FC3 parition.

sfdisk -lV give :
-----------------------------------------------------------
Disk /dev/hda: 79656 cylinders, 16 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Warning: The partition table looks like it was made
  for C/H/S=*/255/63 (instead of 79656/16/63).
For this listing I'll assume that geometry.
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1   *      0+   2103    2104-  16900348+   7  HPFS/NTFS
/dev/hda2       2104    2116      13     104422+  83  Linux
/dev/hda3       2117    3136    1020    8193150   83  Linux
/dev/hda4       3137    4997    1861   14948482+   5  Extended
/dev/hda5       3137+   3267     131-   1052226   82  Linux swap
Warning: partition 1 does not end at a cylinder boundary
Warning: start=63 - this looks like a partition rather than
the entire disk. Using fdisk on it is probably meaningless.
[Use the --force option if you really want this]
------------------------------------------------
The previous attachement is the result of
dd if=/dev/hda of=ghost-broken-table.img bs=512 count=1

Cordialy.
Comment 26 Remi COLLET 2005-01-08 06:00:19 EST
Perhaps it is not a "partition table" problem.

I explain : ghost correctly read the partition table and is able to
"physical" dump it (using -ia) but is unable to "logical" dump it.

So i think of a file system problem.

I've tried to format using FC2 (to avoid the "resize_inode" attribute)
but without more success.

I really need ghost working because i have a lot of PC to deploy FC3 on.

Cordialy.
Comment 27 Remi COLLET 2005-01-17 05:06:12 EST
As this bug is CLOSED, i open a new one on e2fsprogs bug #145307
Comment 28 Red Hat Bugzilla 2006-02-21 14:06:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.