Bug 138868 - anaconda fails during finding packages to upgrade
anaconda fails during finding packages to upgrade
Status: CLOSED DUPLICATE of bug 138485
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 13:08 EST by Miłosz Staszewski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump files from FC2>FC3 update failure (203.21 KB, application/x-gzip)
2004-11-15 13:55 EST, Robert Gadsdon
no flags Details
Anaconda dump files from FC2>FC3 update failure (203.21 KB, application/x-gzip)
2004-11-15 13:56 EST, Robert Gadsdon
no flags Details

  None (edit)
Description Miłosz Staszewski 2004-11-11 13:08:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
When I try to upgrade from FC2 to FC3 anaconda after 'Finding packages
to upgrade' splash gives me the following requester:

Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789, in nextClicked
    self.dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch/py", line
171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py", line
239, in moveStep
    rc = apply(func, sefl.bindArgs(args))
  File "/usr/src/475969-i386/install//usr/lib/anaconda/upgrade.py", line
396, in upgradeFindPackages
    instPath)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/findpackageset.py
", line 149, in findpackageset
    val =
rpm.labelCompare(oevr,(epoch,h[rpm.RPMTAG_VERSION],h[rpm.RPMTAG_RELEASE
]))
TypeError: argument 1, item 0 must be string or None, not long
 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot FC 3installer and choose 'Upgrade existing installation'
2.
3.
    

Additional info:
Comment 1 Jeremy Katz 2004-11-11 14:39:30 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 2 Robert Gadsdon 2004-11-15 13:55:43 EST
Created attachment 106735 [details]
Anaconda dump files from FC2>FC3 update failure

This dump was supposed to be attached to the bugzilla report (according to the
anaconda error message) but bugzilla will not accept it as it is too large!

Will gzip it instead...
Comment 3 Robert Gadsdon 2004-11-15 13:56:37 EST
Created attachment 106736 [details]
Anaconda dump files from FC2>FC3 update failure

Text file is gzip'ed...
Comment 4 Robert Gadsdon 2004-11-15 14:52:31 EST
Apologies for the dupe - upload appeared to 'hang'..

IMHO this does _not_ appear to be a duplicate of #138419, which
appears to relate to disk/partition problems?

Have tried rebuilddb and booting with noapic,nousb etc, but this
appears to be a complete showstopper...    The media has tested OK...
Comment 5 Jeremy Katz 2004-11-15 15:00:01 EST
Whoops, wrong bug #.  Too many numbers in my head :)

*** This bug has been marked as a duplicate of 138485 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:06:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.