Bug 1388696 - Failed to initialize command: Dynflow::ExecutionPlan::Steps::Error - undefined method `ip' for nil:NilClass
Summary: Failed to initialize command: Dynflow::ExecutionPlan::Steps::Error - undefine...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Remote Execution
Version: 6.2.2
Hardware: All
OS: All
urgent
urgent
Target Milestone: Unspecified
Assignee: Adam Ruzicka
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks: 1417074
TreeView+ depends on / blocked
 
Reported: 2016-10-25 23:15 UTC by Marcelo Moreira de Mello
Modified: 2019-12-16 07:14 UTC (History)
7 users (show)

Fixed In Version: rubygem-foreman_remote_execution-0.3.0.14-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1417074 (view as bug list)
Environment:
Last Closed: 2017-03-06 08:33:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
re interface change (80.25 KB, image/png)
2017-02-16 20:33 UTC, jcallaha
no flags Details
verification screenshot (77.93 KB, image/png)
2017-02-16 20:33 UTC, jcallaha
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 14008 0 None None None 2016-10-25 23:15:43 UTC
Red Hat Knowledge Base (Solution) 2726731 0 None None None 2016-10-25 23:19:27 UTC
Red Hat Product Errata RHBA-2017:0447 0 normal SHIPPED_LIVE Satellite 6.2.8 Async Bug Release 2017-03-06 13:23:41 UTC

Description Marcelo Moreira de Mello 2016-10-25 23:15:15 UTC
Description of problem:

When trying to run a remote command it throws the error:

Failed to initialize command: Dynflow::ExecutionPlan::Steps::Error - undefined method `ip' for nil:NilClass

Please backport the issue http://projects.theforeman.org/issues/14008


Version-Release number of selected component (if applicable):
Red Hat Satellite 6.2.2

How reproducible:
100%

Comment 1 Marcelo Moreira de Mello 2016-10-25 23:19:28 UTC
Created article https://access.redhat.com/solutions/2726731

Comment 3 Bryan Kearney 2016-10-26 00:20:25 UTC
Upstream bug assigned to aruzicka

Comment 4 Bryan Kearney 2016-10-26 00:20:27 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/14008 has been resolved.

Comment 7 Ivan Necas 2017-02-06 16:45:19 UTC
Steps to reproduce:

1. in a host, create second interface, check 'Remote Execution' flag, leave ip address blank

2. run a job against the host

Expected result: the execution interface is not considered for computation of ip address, and other interfaces are use for reaching the host

Comment 8 jcallaha 2017-02-16 20:32:36 UTC
Verified in Satellite 6.2.8 Snap 2.

Steps:
1. Enable remote execution on a remote host.
2. Edit the host.
3. Uncheck remote execution from the primary interface.
4. Check remote execution for an alternate interface (see attached).
5. Run a job against the host.

Results:
The job completed successfully (see attached verification screenshot).

Comment 9 jcallaha 2017-02-16 20:33:03 UTC
Created attachment 1250940 [details]
re interface change

Comment 10 jcallaha 2017-02-16 20:33:29 UTC
Created attachment 1250941 [details]
verification screenshot

Comment 12 errata-xmlrpc 2017-03-06 08:33:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0447


Note You need to log in before you can comment on or make changes to this bug.