Bug 138872 - [x86_64]segfaults after today's updates
[x86_64]segfaults after today's updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 13:39 EST by Harold Campbell
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 04:33:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harold Campbell 2004-11-11 13:39:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20041020 Firefox/0.10.1

Description of problem:
After installing the openoffice.org updates OO will no longer run. At
first running ooffice would simply result in a segfault.

[hcamp@localhost dhl]$ ooffice
Segmentation fault

And from the kernel logs:

office.bin[9974]: segfault at 0000000000366dc0 rip 00000000004593ad
rsp 00000000ffffd2f0 error 4


Then I tried nuking my .openoffice directory and the segfault gained
some more information:

[hcamp@localhost ~]$ ooffice
sh: line 1: 10122 Segmentation fault     
LD_LIBRARY_PATH=/usr/lib/ooo-1.1:/usr/lib/ooo-1.1/program
/usr/lib/ooo-1.1/program/setup
-R:/tmp/ooo-wrapper.autoresponse.file.T10120 -v -nogui
>~/.openoffice-install-log 2>&1
Installation of OpenOffice.org 1.1.2 failed:
 'LD_LIBRARY_PATH=/usr/lib/ooo-1.1:/usr/lib/ooo-1.1/program
/usr/lib/ooo-1.1/program/setup
-R:/tmp/ooo-wrapper.autoresponse.file.T10120 -v -nogui >
~/.openoffice-install-log 2>&1'




Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-11.5.fc3

How reproducible:
Always

Steps to Reproduce:
1. Execute openoffice.org any way you like
2. Watch it go boom.
3.
    

Actual Results:  Segmentation fault

Expected Results:  Memory hungry productivity app appears.

Additional info:
Comment 1 Dan Williams 2004-11-11 13:44:35 EST
->cmc, looks like an rpath/LD_LIBRARY_PATH thing?
Comment 2 Caolan McNamara 2004-11-12 03:00:04 EST
caolanm->hcamp: Can you attach the ~/.openoffice-install-log
Comment 3 Harold Campbell 2004-11-12 12:10:59 EST
It's an empty file. 

What I can tell you, though, is that both soffice.bin and setup.bin
segfault right after doing:

getrlimit(RLIMIT_STACK, {rlim_cur=-4284481536, rlim_max=0}) = 0

I'm not sure how simply reading such a strange limit could cause a
segfault, having not used getrlimit myself before and not knowing how
OOo uses the data. It is interesting though that this translates to
0xffffffff00a00000, ie the upper 32 bits all 1s. Then again, OOo is
compiled 32 bit, so perhaps the upper 32 bits are only an strace artifact.

Anyway, this problem might have more to do with the glibc update that
I installed at the same time. glibc-2.3.3-74
Comment 4 Harold Campbell 2004-11-16 11:23:14 EST
I can't think of anything significant which has changed, but OOo is
now working.
Comment 5 Caolan McNamara 2004-11-16 13:00:56 EST
I'm just checking with a pre-rpath change 1.1.2-10 first, can you do
this for me...

> export LD_LIBRARY_PATH=/usr/X11R6/lib:/usr/lib/ooo-1.1/program/
> gdb /usr/lib/ooo-1.1/program/soffice.bin
(gdb) run

I get...

#0  0x0070b0ea in _nl_intern_locale_data () from /lib/tls/libc.so.6
#1  0x0070b2e0 in _nl_load_locale () from /lib/tls/libc.so.6
#2  0x0070ae8e in _nl_find_locale () from /lib/tls/libc.so.6
#3  0x0070a6ac in setlocale () from /lib/tls/libc.so.6
#4  0x00c1ef38 in osl_getTextEncodingFromLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#5  0x00c222a0 in osl_getProcessLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#6  0x00c1edf8 in osl_getTextEncodingFromLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#7  0x00c1fcb1 in osl_setThreadKeyData ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#8  0x00c1f128 in osl_getSystemLocale ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#9  0x00920c2b in pthread_once () from /lib/tls/libpthread.so.0
#10 0x00c1fcee in osl_getThreadTextEncoding ()
   from /usr/lib/ooo-1.1/program/libsal.so.3
#11 0x00c28b7b in osl_syncFile () from
/usr/lib/ooo-1.1/program/libsal.so.3
#12 0x00c1fde6 in osl_loadModule () from
/usr/lib/ooo-1.1/program/libsal.so.3
#13 0xf7fc3a7d in vcl::SolarThreadExecutor::execute ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
#14 0xf7fc4812 in CreateSalInstance ()
   from /usr/lib/ooo-1.1/program/libvcl645li.so
Comment 6 Harold Campbell 2004-11-16 13:38:43 EST
It's not crashing anymore, so there is not much to backtrace. If I
break out to the gdb prompt after OOo comes up and do a backtrace it's
only a couple lines.

Program received signal SIGINT, Interrupt.
[Switching to Thread 4160596192 (LWP 9354)]
0xffffe405 in ?? ()
(gdb) bt
#0  0xffffe405 in ?? ()
#1  0xffffd438 in ?? ()
#2  0x0024b6a4 in poll () from /lib/tls/libc.so.6
Previous frame inner to this frame (corrupt stack?)

Also, there don't seem to be any debuginfo packages available for OOo
to provide debugging symbols.

Do you have some more specific instructions?
Comment 7 Caolan McNamara 2004-11-16 13:52:28 EST
So right now in an unaltered terminal

> oowriter

crashes, while

> export LD_LIBRARY_PATH=/usr/X11R6/lib:/usr/lib/ooo-1.1/program/ 
> oowriter

does not crash ?
Comment 8 Harold Campbell 2004-11-16 14:58:05 EST
Neither crash. Openoffice is working perfectly well now. I suppose
this is a good thing, but it's quite disconcerting because I have no
explanation for it.

Could it have been something to do with prelink? Ie. prelink got a
chance to run and straightned things out?
Comment 9 Jerome Lambert 2004-11-20 18:21:05 EST
I've got the same error, but it has nothing to do with prelink.

I've launch prelink, but nothing changes, and OpenOffice is still
crashing...

By the way, i got this in .openoffice-install-log:
(process:3946): GLib-WARNING **: getpwuid_r(): failed due to:
Permission denied.

I also got a empty file called .openoffice-lock

Comment 10 Jerome Lambert 2004-11-21 05:46:35 EST
It seems that the fault is not in openoffice. I've came back to
openoffice.org-1.1.2-10, and this one is also crashing, with the same
error as above.

But if a start it as root, it is working perfectly...   
Comment 11 Caolan McNamara 2005-01-27 09:42:46 EST
caolanm->Jerome: Is this still broken for you or resolved with the various
updates to FC3, e.g. ooo 1.1.3 et al.
Comment 12 Jerome Lambert 2005-01-28 16:38:59 EST
Updates fixes the problem. I think you can close this bug.

Note You need to log in before you can comment on or make changes to this bug.