Bug 138873 - Automatic partitioning "Could not allocate requested partitons"
Automatic partitioning "Could not allocate requested partitons"
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-11-11 13:57 EST by Youssef Makki
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-11 16:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Youssef Makki 2004-11-11 13:57:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When I chose "Automatically Partition" in the installer, and then
select either "Remove all Linux partitions on this system." or "Keep
all partitions and use existing free space.", I'm presented with 2
error messages. I tried with or without checking the 'review
partitions' box, with the same result.
I can't tell what happens if I chose the third one which deletes all
partitions, I don't want to go that far right now, but I suspect it
would probably be the same. The error messages are as follows,
appearing as 2 consecutive dialog boxes:

"Could not allocate requested partitions:

Unsatisfied partition request
New Part Request -- mountpoint: None uniqueID: 3
  type: physical volume (LVM) format: 1 badblocks: None
  device: None drive: ['hda'] primary: None
  size: 0 grow: 1 maxsize: None
  start: None end: None migrate: None origfstype: None"

When you hit 'OK' here, the second error comes up:

"The following errors occurred with your partitioning:
You have not defined a root partition (/), which is requred for
installation of Fedora Core to continue.
This can happen if there is not enough space on your hard drive(s) for
the installation.
You can chose a different auto partitioning option, or click 'Back' to
select manual partitioning.
Press 'OK' to continue."

If I go back and chose the manually partition option, it moves on
gracefully to the partition editor where my drive appears. I have not
tried to do anything there yet.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot installation cd with no extra parameters
2. Select "Automatically Partition"
3. Select "Remove all Linux partitions on this system" OR select "Keep
all partitions and use existing free space"
4. Click 'Next'

Actual Results:  The above mentioned error messages appear consecutively.

Expected Results:  What the chosen options should do.

Additional info:

My hardware configuration:

Pentium 4 2.8 with HT enabled on an Intel D875PBZ motherboard with 1gb
A 40GB hard drive split into 2 equally sized partitions, the first
having a working installation of Windows XP, and the second being
unpartitioned space.
Comment 1 Jeremy Katz 2004-11-11 14:37:51 EST
How did you have the machine partitioned previously?
Comment 2 Youssef Makki 2004-11-11 15:15:29 EST
The hard drive was initially partitioned a long time ago using a
Windows bootdisk iirc. It did however work fine the exact same way
when I installed FC2, what I did is simply delete all FC2 partitions
through the XP disk manager, and try this now.

I've managed to install FC3 successfully using manual partitioning, I
added a 100MB /boot, a 2048MB /swap, and a / partition filling all
remaining space. I installed grub to the first bootsector, it boots
fine using the XP loader (and a linux.bin), here's the output of fdisk -l:

Disk /dev/hda: 40.0 GB, 40020664320 bytes
16 heads, 63 sectors/track, 77545 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1       38772    19541056+   7  HPFS/NTFS
/dev/hda2           38776       38984      104422+  83  Linux
Partition 2 does not end on cylinder boundary.
/dev/hda3           38984       43143     2096482+  82  Linux swap
Partition 3 does not end on cylinder boundary.
/dev/hda4           43143       77536    17334135    5  Extended
Partition 4 does not end on cylinder boundary.
/dev/hda5           43143       77536    17334103+  83  Linux

Disk /dev/hdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1        9729    78148161    c  W95 FAT32 (LBA)
/dev/hdb2            9730       19457    78140160    f  W95 Ext'd (LBA)
/dev/hdb5            9730       19457    78140128+   b  W95 FAT32
Comment 3 Jeremy Katz 2004-11-11 16:48:14 EST
I think I committed a fix for this.  You managed to get a workaround.
Comment 4 Myk Melez 2005-02-18 17:25:39 EST
I see the same thing after using qtparted to resize the NTFS partition
on my new IBM laptop so that I have 40GB free space for FC3.  I
initially left the space unformatted, but after getting the error
message I used qtparted to format it ext3.  I still got the same error
message, though, the only difference being that my "uniqueID" is "36".

Note You need to log in before you can comment on or make changes to this bug.