Bug 138877 - "cdrecord -scanbus" differs between root and normal user
"cdrecord -scanbus" differs between root and normal user
Status: CLOSED DUPLICATE of bug 138739
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 14:20 EST by David Masterson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Masterson 2004-11-11 14:20:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
When I run "cdrecord -scanbus" as a normal user, I get the expected
list of my CD drives (I have a DVD and a CD) on channel 1 of the SCSI
controller.  When I run "cdrecord -scanbus" as the root user, it only
reports the SCSI disk drives on channel 0.  Therefore, I cannot use
cdrecord to cut the CDs for Fedora3 and, thus, this should be a high
priority bug.

Output of "cdrecord -scanbus" as normal user:
=============================================
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) 'YAMAHA  ' 'CRW2200E        ' '1.0D' Removable CD-ROM
        1,1,0   101) 'SONY    ' 'DVD-ROM DDU1621 ' 'S1.6' Removable CD-ROM
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
=============================================

Output of "cdrecord -scanbus" as root user:
=============================================
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
J�rg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
Linux sg driver version: 3.5.31
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus0:
        0,0,0     0) 'IBM     ' 'DDYS-T18350N    ' 'S96H' Disk
        0,1,0     1) 'IBM     ' 'DDYS-T18350N    ' 'S96H' Disk
        0,2,0     2) 'IBM     ' 'DDYS-T18350N    ' 'S96H' Disk
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
=============================================

Version-Release number of selected component (if applicable):
cdrecord-2.01.1-0.FC2.1

How reproducible:
Always

Steps to Reproduce:
1.As normal user, run "cdrecord -scanbus"
2.As root user, run "cdrecord -scanbus"
3.Compare outputs
    

Actual Results:  cdrecord does not report my CD & DVD when running a
scanbus as root user whereas it does when run as normal user.

Expected Results:  cdrecord should report the same things during a
scanbus as both root and a normal user.

Additional info:

The configuration of my system is as follows:

Fedora Core 2 and Windows 98 on ...
ASL Marquis K121 dual CPU AMD Athlon MP 1800+ system w/ 1Gb RAM
Adaptec 29160 Ultra-SCSI w/ 3 IBM UltraStar disk drives
ASUS V7100 GeForce2 MX 32Mb AGP video card w/ ViewSonic VA720
Intel EtherExpress Pro+ 10/100Mbps Ethernet adapter
Soundblaster 128 PCI Sound card
DVD and CDRW disk drives
USR Sportster 56K modem
Kinesis keyboard and Logitech Trackman Wheel
Comment 1 Harald Hoyer 2004-11-12 04:47:59 EST
try scanbus with with disks inserted

*** This bug has been marked as a duplicate of 138739 ***
Comment 2 David Masterson 2004-11-13 01:19:41 EST
I'll followup to new bug also, but I'll add here as well.

I tried "scanbus" with disks inserted, but it had no effect.  Note the
differences between the scanbus output -- they are very different with
respect to the SCSI channels interrogated.  Root is not seeing my CD
drives.
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.