Bug 13888 - GUI install w/ wrong DNS IP: localhost.localdomain used, /etc/hosts wrong.
GUI install w/ wrong DNS IP: localhost.localdomain used, /etc/hosts wrong.
Status: CLOSED DUPLICATE of bug 13486
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-13 04:32 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-15 11:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-07-13 04:32:59 EDT
I did a fresh GUI workstation install.

This computer has two network interfaces.  I chose to enable eth0 in
install, entered all data for it including the hostname.  HOWEVER, I put in
a   
wrong IP for DNS server.  This (either just GUI or both GUI and wrong IP)
causes the following:
 - /etc/hosts is setupped wrong: myhost.mydoma.in etc. are in localhost   
line
 - /etc/sysconfig/network etc. define hostname as localhost.localdomain.

I haven't done any GUI installs since RH 6.1, so I don't know if this
issue is with the wrong DNS server or something else.
  
TUI installs using _correct_ DNS address works fine.   Haven't tried with
wrong address.
Comment 1 Peter Petrakis 2000-07-14 10:08:45 EDT
NFS install, have been able to reproduce consistantly on Alpha with one network
card. It will set the proper hostname in /etc/hosts but /etc/sysconfig/network
will still say localhost.localdomain.

Comment 2 Matt Wilson 2000-07-15 11:40:26 EDT
User error - use the right IP for the DNS.
Comment 3 Pekka Savola 2000-07-15 11:58:36 EDT
I beg to differ.

The installer asks for [IIRC]
 - hostname
 - IP
 - default gateway
 - nameservers

If all the other entries are filled correctly, why should an incorrect
nameserver entry cause them to be configured wrong?

I think that hostname should automatically be entered into
/etc/sysconfig/network.  Also, IP address, hostname -pair should be written to
/etc/hosts from the settings above.  And lastly, /etc/resolv.conf would have the
nameservers as defined.

Now entering a wrong nameserver entry kills (almost) the whole network
configuration, so to speak.  What if the user just wanted to install from a site
where there actually is no connectivity yet (It's a CD-ROM install after all..)?


Comment 4 Pekka Savola 2000-08-07 04:04:14 EDT

*** This bug has been marked as a duplicate of 13486 ***

Note You need to log in before you can comment on or make changes to this bug.