Bug 138880 - eata driver missing on the boot cd
Summary: eata driver missing on the boot cd
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 19:36 UTC by Frode Tennebø
Modified: 2015-01-04 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-24 00:20:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frode Tennebø 2004-11-11 19:36:42 UTC
Description of problem:
Boot on CD1 and wait until it is finished scanning for installation 
(my root & boot FSs are on an ide disk, but the rest is on SCSI). Got 
to console and do "fdisk -l"  no SCSI disks appear.

Version-Release number of selected component (if applicable):
Fedora Core 3

How reproducible:
always

Steps to Reproduce:
1.boot
2.
3.
  
Actual results:
No eata module loaded. No SCSI disks present.

Expected results:
eata module loaded and SCSI disks present.

Additional info:
I tried "modprobe eata", but it appears that this module is not 
included....

Comment 1 Frode Tennebø 2005-05-04 14:20:39 UTC
This is an irritating bug since it "forced me" to perform a fresh installtion 
(well, it was due, I have been upgrading since RH4.2). However, every update 
kernel since has also lacked this driver which again "forces me" to recompile 
the .src distribution.

Comment 2 Dave Jones 2005-07-15 18:23:53 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 3 Frode Tennebø 2005-07-16 13:50:27 UTC
This is still the case:

[root@leia linux]# cat configs/kernel-2.6.12-i686.config | grep EATA
# CONFIG_SCSI_EATA is not set


Comment 4 Dave Jones 2005-08-04 19:01:20 UTC
this code is unmaintained upstream, and from a quick eyeball, looks very dated.
(It even implements its own queueing algorithm instead of using the block layer).

I'm surprised to hear that it even builds.
Given this is the only request we've had to enable this driver, I'm not overly
enthusiastic about enabling it.


Comment 5 Frode Tennebø 2005-08-07 22:01:17 UTC
I have been in contact with the maintainer of the driver, Dario Ballabio, and he 
says he still maintains it if need be (even though, somebody has recently 
reformated the code without his knowledge). He also claims that it does not have 
its own queueing mechanism, and I quote "It is a standard compliant low level 
driver, with the additional optional feature of sorting requests not yet sent to 
the device."

I ask for a reconsideration. :)

Comment 6 Dave Jones 2005-09-24 00:20:42 UTC
The potential for problems is far greater than the benefits.
As mentioned above, yours is the only request we've ever had for this.


Comment 7 Frode Tennebø 2005-09-25 22:52:20 UTC
Now, if only I'm using the module, what potential problems could that be? ;-)

Seriously, I'm curious about the nature of these potential problems since the 
author/maintainer of the driver does not seem to share your concerns.


Note You need to log in before you can comment on or make changes to this bug.