Bug 1388836 - CephBase visibility issue when using ExternalCeph
Summary: CephBase visibility issue when using ExternalCeph
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-26 09:37 UTC by Attila Fazekas
Modified: 2016-12-14 16:25 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:25:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 394993 None None None 2016-11-08 14:38:03 UTC
Launchpad 1635014 None None None 2016-10-26 09:37:50 UTC

Description Attila Fazekas 2016-10-26 09:37:01 UTC
When I try to make deployment based on the environments/puppet-ceph-external.yaml example it fails with:

Failed to validate nested template: Failed to validate: resources[2]: Validation error in output "role_data": The specified reference "CephBase" (in unknown) is incorrect.',
 u'status': u'FAILED'}

Version-Release number of selected component (if applicable):

openstack-tripleo.noarch             0.0.8-0.2.4de13b3git.el7ost
openstack-tripleo-common.noarch      5.3.0-3.el7ost     @rhelosp-10.0-puddle    
openstack-tripleo-heat-templates.noarch
openstack-tripleo-image-elements.noarch
openstack-tripleo-puppet-elements.noarch
openstack-tripleo-ui.noarch          1.0.4-2.el7ost     @rhelosp-10.0-puddle    
openstack-tripleo-validations.noarch 5.1.1-0.20161003173643.3652f12.el7ost
puppet-tripleo.noarch                5.3.0-3.el7ost     @rhelosp-10.0-puddle    
python-tripleoclient.noarch          5.3.0-2.el7ost     @rhelosp-10.0-puddle  


The same settings was valid 1 month before, and no intentional related change found in the git history so far.

Comment 2 Yogev Rabl 2016-11-07 09:05:13 UTC
Attila, can you please provide us with the network configuration and the external ceph environment file

Comment 3 Marius Cornea 2016-11-08 07:33:13 UTC
I hit the same issue on my environment. Applying https://review.openstack.org/#/c/392558/ made it pass.

Comment 4 Attila Fazekas 2016-11-08 08:13:00 UTC
@ceph env:
parameter_defaults:
    CinderEnableIscsiBackend: false
    CinderEnableRbdBackend: true
    CinderEnableNfsBackend: false
    NovaEnableRbdBackend: true
    GlanceBackend: rbd
    CinderRbdPoolName: "automation-volumes"
    NovaRbdPoolName: "automation-vms"
    GlanceRbdPoolName: "automation-images"
    CephClientUserName: "automation"
    CephClientKey: "secret base64"
    CephClusterFSID: "I do not tell my ID"
    CephExternalMonHost: "10.35.65.98, 10.35.65.100, 10.35.65.102"

resource_registry:
    OS::TripleO::Services::CephExternal: /usr/share/openstack-tripleo-heat-templates/puppet/services/ceph-external.yaml
    OS::TripleO::Services::CephMon: OS::Heat::None
    OS::TripleO::Services::CephClient: OS::Heat::None
    OS::TripleO::Services::CephOSD: OS::Heat::None

@net_env_root:
resource_registry:
  OS::TripleO::BlockStorage::Net::SoftwareConfig: three-nics-vlans/cinder-storage.yaml
  OS::TripleO::Compute::Net::SoftwareConfig: three-nics-vlans/compute.yaml
  OS::TripleO::Controller::Net::SoftwareConfig: three-nics-vlans/controller.yaml
  OS::TripleO::ObjectStorage::Net::SoftwareConfig: three-nics-vlans/swift-storage.yaml
  OS::TripleO::CephStorage::Net::SoftwareConfig: three-nics-vlans/ceph-storage.yaml

parameter_defaults:
    ExternalNetCidr: '10.0.0.0/24'
    ExternalAllocationPools: [{'start': '10.0.0.101', 'end': '10.0.0.149'}]
    ExternalInterfaceDefaultRoute: '10.0.0.1'
    ExternalNetworkVlanID: 10
    InternalApiNetCidr: '172.17.1.0/24'
    InternalApiAllocationPools: [{'start': '172.17.1.10', 'end': '172.17.1.200'}]
    InternalApiNetworkVlanID: 20
    StorageNetCidr: '172.17.3.0/24'
    StorageAllocationPools: [{'start': '172.17.3.10', 'end': '172.17.3.200'}]
    StorageNetworkVlanID: 30
    StorageMgmtNetCidr: '172.17.4.0/24'
    StorageMgmtAllocationPools: [{'start': '172.17.4.10', 'end': '172.17.4.200'}]
    StorageMgmtNetworkVlanID: 40
    TenantNetCidr: '172.17.2.0/24'
    TenantAllocationPools: [{'start': '172.17.2.10', 'end': '172.17.2.200'}]
    TenantNetworkVlanID: 50
    DnsServers: ['10.0.0.1']
    EC2MetadataIp: 192.0.2.1
    ControlPlaneDefaultRoute: 192.0.2.1
    ControlPlaneSubnetCidr: "24"
    NeutronExternalNetworkBridge: "''"

Comment 6 Alexander Chuzhoy 2016-11-09 20:22:39 UTC
Reproduced the issue.
Proceeded after applying the patch in comment #3.
Thanks.

Comment 8 John Fulton 2016-11-15 21:26:14 UTC
There have been other tests of external ceph, e.g. 1394587 [1] and 1393581 [2], which have not run into this problem after the patch was applied. For this reason I am marking the fix as verified. 

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1394587
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1393581

Comment 10 errata-xmlrpc 2016-12-14 16:25:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.