Bug 138897 - /dev/isdnctrl is not created
Summary: /dev/isdnctrl is not created
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: MAKEDEV   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-11 20:56 UTC by Ronny Buchmann
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 21:21:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace MAKEDEV (529.63 KB, text/plain)
2004-11-12 07:45 UTC, Ronny Buchmann
no flags Details
Not creating Lnk_Files with the correct context. (388 bytes, patch)
2004-11-12 19:37 UTC, Daniel Walsh
no flags Details | Diff

Description Ronny Buchmann 2004-11-11 20:56:33 UTC
Description of problem:
"/sbin/MAKEDEV isdn" doesn't create /dev/isdnctrl (which should be a
symlink to /dev/isdnctrl AFAIK)

Version-Release number of selected component (if applicable):
MAKEDEV-3.13-1

Comment 1 Ronny Buchmann 2004-11-11 21:16:33 UTC
audit(1100206012.521:0): avc:  denied  { create } for  pid=2149
exe=/sbin/MAKEDEV name=isdnctrl scontext=user_u:system_r

actually seems to be a selinux problem

Comment 2 Ronny Buchmann 2004-11-11 21:25:33 UTC
The interesting thing is, I can create the link manually without problems.

[root@bserv dev]# rm -f isdn*
[root@bserv dev]# id
uid=0(root) gid=0(root)
Gruppen=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel)
context=root:system_r:unconfined_t
[root@bserv dev]# /sbin/MAKEDEV isdn
error making /dev/isdnctrl: Permission denied
[root@bserv dev]# dmesg|tail -1
audit(1100208530.931:0): avc:  denied  { create } for  pid=5649
exe=/sbin/MAKEDEV name=isdnctrl scontext=root:system_r:unconfined_t
tcontext=system_u:object_r:tty_device_t tclass=lnk_file
[root@bserv dev]# ln -s isdnctrl0 isdnctrl


Comment 3 Daniel Walsh 2004-11-12 01:06:11 UTC
It is blowing up trying to create a lnk file as a tty device.

Can you do a setenforce 0 and then run the MAKEDEV and then attach the
avc messages.

Dan

Comment 4 Ronny Buchmann 2004-11-12 07:39:08 UTC
[root@bserv dev]# setenforce 0
[root@bserv dev]# /sbin/MAKEDEV isdn
[root@bserv dev]# dmesg|tail -1
audit(1100245234.042:0): avc:  denied  { create } for  pid=15098
exe=/sbin/MAKEDEV name=isdnctrl scontext=root:system_r:unconfined_t
tcontext=system_u:object_r:tty_device_t tclass=lnk_file
[root@bserv dev]# rm -f isdn*
[root@bserv dev]# strace -o /root/makedev-isdn-trace /sbin/MAKEDEV isdn


Comment 5 Ronny Buchmann 2004-11-12 07:45:07 UTC
Created attachment 106554 [details]
strace MAKEDEV

[root@bserv dev]# ls -lZ isdnctrl
lrwxrwxrwx  root     root     system_u:object_r:tty_device_t   isdnctrl ->
isdnctrl0

Comment 6 Ronny Buchmann 2004-11-12 07:46:45 UTC
[root@bserv dev]# rm -f isdnctrl
[root@bserv dev]# ln -s isdnctrl0 isdnctrl
[root@bserv dev]# ls -lZ isdnctrl
lrwxrwxrwx  root     root     root:object_r:device_t          
isdnctrl -> isdnctrl0

Comment 7 Daniel Walsh 2004-11-12 19:37:33 UTC
Created attachment 106599 [details]
Not creating Lnk_Files with the correct context.

This patch fixes problem

Comment 8 Nalin Dahyabhai 2004-11-12 21:21:58 UTC
Good catch!  Merging into 3.15-1 and later.

Comment 9 Colin Charles 2004-11-24 10:08:46 UTC
Any chance an FC3 update will get pushed Nalin?

Comment 10 André Johansen 2005-10-26 20:42:19 UTC
Using a recompiled MAKEDEV package from FC4 in FC3 seems to fix the issue for 
me. 


Note You need to log in before you can comment on or make changes to this bug.