Bug 1388981 - When token expires, user should be logged out of the GUI
Summary: When token expires, user should be logged out of the GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Honza Pokorny
QA Contact: Ola Pavlenko
RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-26 15:33 UTC by Jason E. Rist
Modified: 2016-12-14 16:25 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-ui-1.0.4-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:25:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 395596 None None None 2016-11-10 05:49:47 UTC
Launchpad 1626556 None None None 2016-10-26 15:33:05 UTC

Description Jason E. Rist 2016-10-26 15:33:02 UTC
Cloned from launchpad bug 1626556.

Description:

When the token expires (after 4 hour by default on the undercloud), the GUI starts to spit out lots of error alerts, and the pages display lots of zeros and blanks instead of real data. Instead, the user should simply be directed back to the login page (or pop up a dialog to get the password again). If possible, the user should then be taken to the page he was trying to go to.

Specification URL (additional information):

https://bugs.launchpad.net/tripleo/+bug/1626556

Comment 2 Anandeep Pannu 2016-11-10 17:33:07 UTC
@Scott Lewis - I PM acked this - I assume the needinfo can be cleared?

Comment 4 Jason E. Rist 2016-11-17 22:07:30 UTC
FailedQA

:(

I tried doing this and there didn't seem to be a real timeout. 

Steps to reproduce:
1.) Log in
2.) Open Register Nodes dialog
3.) Don't touch browser for 4 hours
4.) User is not logged out when token expires
5.) Any actions on the UI then create errors

This is with:
cat /var/lib/rhos-release/latest-installed
10   -p 2016-11-15.2

Comment 5 Jason E. Rist 2016-11-18 16:05:27 UTC
Sorry, it was explained to me that the logout happens upon API call which is specified in the original bug.  

After testing again, this works fine.

Moving back to ON_QA and then VERIFIED.

Comment 7 errata-xmlrpc 2016-12-14 16:25:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.