Bug 1389057 - Additions/changes to eclipse.ini to support webtools (nashorn extension) and provide more memory to Eclipse for use with devstudio
Summary: Additions/changes to eclipse.ini to support webtools (nashorn extension) and ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: eclipse
Version: rh-eclipse46
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.3
Assignee: Mat Booth
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-26 18:10 UTC by Nick Boldt
Modified: 2016-11-15 10:15 UTC (History)
5 users (show)

Fixed In Version: rh-eclipse46-eclipse-4.6.1-2.3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 10:15:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to increase -Xms and add nashorn extension (1.46 KB, patch)
2016-10-26 18:44 UTC, Nick Boldt
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1380438 None None None 2016-10-26 18:49:15 UTC
Red Hat Product Errata RHEA-2016:2742 normal SHIPPED_LIVE new packages: rh-eclipse46 2016-11-15 14:52:38 UTC

Internal Links: 1459637

Description Nick Boldt 2016-10-26 18:10:25 UTC
Description of problem:

Current eclipse.ini file sets too low a default minimum for java memory (-Xms) and as noted in #1380438 web tooling doesn't work correctly with JS unless you add this to your eclipse.ini:

-Dosgi.framework.extensions=org.eclipse.wst.jsdt.nashorn.extension

Version-Release number of selected component (if applicable):

http://pkgs.devel.redhat.com/cgit/rpms/eclipse/tree/eclipse.spec?h=rhscl-2.3-rh-eclipse46-rhel-7#n717


How reproducible:

Always

Steps to Reproduce:
1. See #1380438
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nick Boldt 2016-10-26 18:44:13 UTC
Created attachment 1214386 [details]
patch to increase -Xms and add nashorn extension

Since this issue is not ACK'd, I can't just push in the commit I'm suggesting, so in order to be able to actually do a peer review here, I've attached it as a patch instead.

Comment 2 Mat Booth 2016-10-27 09:49:39 UTC
Looks like you managed to push the patch, so I fired off a build

Comment 4 Václav Kadlčík 2016-10-27 13:35:06 UTC
verified:
rh-eclipse46-eclipse-platform-4.6.1-2.3.el7

Comment 6 errata-xmlrpc 2016-11-15 10:15:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2742.html


Note You need to log in before you can comment on or make changes to this bug.