Bug 138906 - USB 2.0 flash disk not recognized on USB 2.0 port, is recognized on USB 1.1 port
USB 2.0 flash disk not recognized on USB 2.0 port, is recognized on USB 1.1 port
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 16:30 EST by Tim Taylor
Modified: 2013-03-05 22:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 14:20:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal dump before inserting my usb pendrive (51.26 KB, text/plain)
2004-12-01 15:38 EST, Frederic JECKER
no flags Details
lshal dump after inserting my usb key (71 bytes, text/plain)
2004-12-01 15:41 EST, Frederic JECKER
no flags Details
hal --daemon=np --verbose=yes device probing part (27.35 KB, text/plain)
2004-12-14 15:55 EST, Frederic JECKER
no flags Details
hal --daemon=no --verbose=yes output after plugin my usb key (17.39 KB, text/plain)
2004-12-14 15:57 EST, Frederic JECKER
no flags Details

  None (edit)
Description Tim Taylor 2004-11-11 16:30:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Running FC3 on AMD 3200+ with USB 2.0 ports.  When insert Sandisk mini
cruzer 1.0GB drive, drive is seen by usbview, but not mounted, nor
added to fstab.  When inserting this same flash drive into another PC
running FC3 with USB 1.1 ports, drive is auto-mounted, icon appears on
desktop, icon appears in nautilus under 'computer'.  


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert flash drive
2.
3.
    

Actual Results:  usbview sees flash drive under EHCI controller.  No
icon on desktop, no icon in nautilus under 'computer'.

Expected Results:  icon on desktop, icon in nautilus

Additional info:

when I had FC2 on this PC, I had the same problem.  To fix it, I
removed the line in /etc/modprobe.conf that had 'ehci' in it, and then
flash drive would be seen as USB 1.1 device.  I tried this on FC3, but
the flash drive still shows up as USB 2.0 device.
Comment 1 Kevin Fries 2004-11-17 14:03:17 EST
I do not even get this far.  I plug in my flash stick and it blinks as
if it is being mounted.  But then nothing... lsusb shows only the usb
hubs no devices, ditto usbview.  In the past I would just mount
/dev/sda1, but that does not seem to exist either.  I did notice a
/mnt/removable directory create once I plugged the stick in, but
nothing mounted to it.  Nothing in /media either which is where I
expected the device to mount (since cd and floppy were moved there).

Its as if, FC3 sees the drive, but refuses to use it.

All help greatly appreciated.  Once server in particular is backed up
via USB hard drive, and until this is fixed, this is a show stopper!

Thx
Comment 2 Frederic JECKER 2004-12-01 15:37:17 EST
Same problem here with a SanDisk Cruzer Mini 128 USB2 key on my laptop
(toshiba P10 104) USB2 ports
It seems that the key get recognized (led blinks) but not
automatically mounted like it should be.
It's like Haldeamon fails when the key is plugged
I've added to the bug two attachments :
Before.txt: lshal dump before plugging my USB key
After.txt: lshal dump after the key has been connected.


Comment 3 Frederic JECKER 2004-12-01 15:38:41 EST
Created attachment 107732 [details]
lshal dump before inserting my usb pendrive
Comment 4 Frederic JECKER 2004-12-01 15:41:12 EST
Created attachment 107733 [details]
lshal dump after inserting my usb key
Comment 5 Frederic JECKER 2004-12-02 00:45:22 EST
I just up2dated the latest HAL release (0.4.2) and it hasn't solved
the problem.
HAL keeps on freezing when I plug my USB key.
Comment 6 Thomas Woerner 2004-12-02 05:34:18 EST
Assigning to hal.
Comment 7 David Zeuthen 2004-12-02 10:33:19 EST
This is a known issue with the usb-storage driver - it is being
tracked in bug 136255.

*** This bug has been marked as a duplicate of 136255 ***
Comment 8 Kevin Fries 2004-12-03 12:05:57 EST
This is not a duplicate but instead a second and seperate issue
against the same driver.

When I plug in my USB device on an FC3 machine, it does not hang
anything, Fedora flat does not see it!

I have one thing to add though... I have a laptop that I know works
with USB 2 devices (a Sony Viao Z505) that does see the memory sticks.
 The only difference that I can see is that the Viao has the memory
stick adapter and therefore dev sees the /dev/sda tree.  But with my
other machines, no such device exists, and therefore no /dev/sda to
attach the memory stick to.

AGAIN... No zombie processes on this end, this is a seperate issue and
not a duplicate!
Comment 9 David Zeuthen 2004-12-03 12:25:04 EST
OK, please attach the output of 'hald --daemon=no --verbose=yes' when
plugging in the device. You need to ensure that hald is not already
running, you can do this with 'service haldaemon stop'.
Comment 10 Need Real Name 2004-12-05 19:55:55 EST
I have a 256MB SanDisk Cruzer Mini, and whenever I boot up, the first
time I plug it in, it works fine, however if i unmount and unplug it,
and then plug it back in, it no longer automounts. (the same problem
as the bug). I have NOT updated hal, and I have NO clue what is going on.
Comment 11 Frederic JECKER 2004-12-14 15:55:31 EST
Created attachment 108566 [details]
hal --daemon=np --verbose=yes device probing part
Comment 12 Frederic JECKER 2004-12-14 15:57:51 EST
Created attachment 108567 [details]
hal --daemon=no --verbose=yes output after plugin my usb key
Comment 13 Frederic JECKER 2004-12-14 15:58:48 EST
Hello, 

I added the hal verbose output to the bug.
If you need other info ask me

Fre
Comment 14 Tim Taylor 2004-12-22 20:36:12 EST
Update to original report:
I bought an external USB 1.1 hub, plugged it into the USB 2.0 port on
the PC and then plugged the Sandisk mini cruzer into the USB 1.1 hub
and it works fine - hal detects the flash drive as a USB 1.1 device
and everything is ok.  I dual boot this PC and the flash drive works
fine as a USB 2.0 device on Windows XP.
Comment 15 Tim Taylor 2005-01-10 14:54:26 EST
Another update - I disabled acpi and now it works perfectly.  I
unchecked acpid in Services, and also added 'acpi=off' in the kernel
line in /boot/grub/grub.conf.
Comment 16 David Zeuthen 2005-01-13 14:20:35 EST
I think also that kernel 2.6.10 and later have much improved USB
Storage support. Closing this bug as it really concerns the USB
drivers in the kernel.
Comment 17 Frederic JECKER 2005-01-20 02:48:43 EST
FYI :
I really needed my usb key to work so I bought a Iomega Mini usb2 key
Plugged it in and miracle! it worked.
So I definitively think that the Sandisk Cruzer Mini series have
something particular....
Comment 18 David Zeuthen 2005-01-20 10:30:22 EST
Yeah, some specific devices are troublesome unfortunately; FWIW, a
friend of mine got a Sandisk Cruzer Mini 256MB (with the blue led)
that works fine; it might be a different revision of the chipset 

Note You need to log in before you can comment on or make changes to this bug.