Bug 1389189 - Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Cannot alias Host
Summary: Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Cannot ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: Sergii Nozhka
URL:
Whiteboard:
: 1389748 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-27 07:02 UTC by Attila Fazekas
Modified: 2016-12-14 16:26 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.9.0rc3.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, due to a race condition between Hiera data getting written and Puppet execution on nodes, Puppet on the Overcloud nodes failed occasionally due to the missing Hiera data. With this update, ordering is introduced, first writing of the Hiera data is completed on all nodes and then Puppet execution takes place. As a result, Puppet no longer fails during execution as all the necessary Hiera data is present.
Clone Of:
Environment:
Last Closed: 2016-12-14 16:26:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 387982 None None None 2016-10-27 07:03:45 UTC
Launchpad 1633565 None None None 2016-10-27 07:03:17 UTC

Description Attila Fazekas 2016-10-27 07:02:55 UTC
Multiple setup failed with 

Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Cannot alias Host[external] to [""]; resource ["Host", ""] already declared at /etc/puppet/modules/tripleo/manifests/vip_hosts.pp:37


openstack-tripleo-heat-templates.noarch                                     5.0.0-0.8.0rc3.el7ost


The issue already known at upstream:
https://bugs.launchpad.net/tripleo/+bug/1633565

Comment 1 Jon Schlueter 2016-10-28 19:32:01 UTC
*** Bug 1389748 has been marked as a duplicate of this bug. ***

Comment 5 Sergii Nozhka 2016-11-07 16:43:37 UTC
The issue not reproduced with openstack-tripleo-heat-templates-5.0.0-1.2.el7ost.noarch.

Comment 8 errata-xmlrpc 2016-12-14 16:26:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.