Bug 138922 - unable to change pcm volume level
unable to change pcm volume level
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 17:49 EST by Bernd Bartmann
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-11-11 17:49:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Several of the sound volume sliders are not available for me. This
happens on a freshly installed FC3 system. The function of the
soundcard (snd_via82xx) has been verified in firstboot. I installed
the xmms-mp3 plugin from freshmeat and can hear mp3 soundtracks but
the volume seems to be set to 100%. So I tried to change the volume
level using alsamixer and gnome-mixer. The master-volume slider has no
effect at all and strange enough I see a PCM field but no slider is
associated to it. There are also several other sliders missing
(Line-In, Mic, ...).

So sound itself seems to work but I can't change the volume settings.

 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to change sound volume settings 
2.
3.
    

Additional info:
Comment 1 Bernd Bartmann 2004-11-12 12:54:46 EST
Additonal note:

When I scroll to the right end of gnome-mixer or alsamixer I find 4
sliders all named VIA DXS. The first one of these indeed does control
the volume for me, but it is unclear if this is the PCM or master volume.
Comment 2 Dave Jones 2005-07-15 16:18:45 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Bernd Bartmann 2005-07-15 16:45:29 EDT
Thanks Dave. The system has been upgraded to FC4 in the meantime and now the
volume sliders work as expected.

Note You need to log in before you can comment on or make changes to this bug.