Bug 138925 - checking if UIC has KDE plugins available... no. i HAVE kdelibs-dev
checking if UIC has KDE plugins available... no. i HAVE kdelibs-dev
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 18:03 EST by Mattias Larsson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 14:05:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Larsson 2004-11-11 18:03:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20041020 Firefox/0.10.1

Description of problem:
When i configure a kde-program. I get 

checking if UIC has KDE plugins available... no
configure: error: you need to install kdelibs first.


config.log gives error at the line 
/usr/lib64/qt-3.3/bin/uic -L /usr/lib/kde3/plugins/designer -nounload
 actest.ui > actest.cpp

when i try to run it in console i get 
 uic: Could not open file 'actest.ui'

Version-Release number of selected component (if applicable):
6:3.3.1-2.2

How reproducible:
Always

Steps to Reproduce:
1.configure kde-app
2.
3.
    

Actual Results:  see description

Expected Results:  configure should have went through

Additional info:
Comment 1 Jordan Benjamin 2004-11-22 16:12:25 EST
This is apparently a bug in the configuration of KDE or QT shipped  
with FC3. There is a FAQ on this:  
http://developer.kde.org/documentation/other/developer-faq.html#q2.23  
Unfortunately I don't find it even remotely useful since I'm not a  
KDE guru.   
Comment 2 Sebastian Sala 2005-07-15 15:51:47 EDT
The same problem is with Fedora 4 x86_64
Comment 3 Ngo Than 2005-07-18 07:35:58 EDT
I don't think it's a bug in our KDE, it looks a bug in the configure from your
kde-program. Could you plese tell me which kde-program has this problem? Thanks
Comment 4 Sebastian Sala 2005-07-18 13:28:26 EDT
krusader, superkaramba, kasablanca and every program which needs kdelibs. 
Comment 5 Ngo Than 2005-07-18 14:05:40 EDT
i'm surely it's a bug in the configure script. Most of them does not detect lib64
correctly. You should please try to add following options 

 --with-qt-libraries=$QTDIR/lib \
 --enable-libsuffix=64

it will fix the rebuild problem.

Note You need to log in before you can comment on or make changes to this bug.