Bug 1389295 - Unable to select image source
Summary: Unable to select image source
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-horizon
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Radomir Dopieralski
QA Contact: Ido Ovadia
URL:
Whiteboard:
: 1382007 (view as bug list)
Depends On:
Blocks: 1382039
TreeView+ depends on / blocked
 
Reported: 2016-10-27 11:53 UTC by Ido Ovadia
Modified: 2016-12-14 16:26 UTC (History)
11 users (show)

Fixed In Version: puppet-horizon-9.4.1-1.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-12-14 16:26:06 UTC


Attachments (Terms of Use)
create_image_screenshot (121.86 KB, image/png)
2016-10-27 11:53 UTC, Ido Ovadia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 391825 None None None 2016-10-31 15:28:40 UTC

Description Ido Ovadia 2016-10-27 11:53:37 UTC
Created attachment 1214578 [details]
create_image_screenshot

Description of problem:
=======================
User cannot create an image on Horizon

The following error appears on Create Image wizard

" The current Horizon settings indicate no valid image creation methods are available. Providing an image location and/or uploading from the local file system must be allowed to support image creation."

Version-Release number of selected component:
=============================================
python-django-horizon-10.0.0-3.el7ost.noarch
puppet-horizon-9.4.0-1.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Deploy undercloud and overcloud 
2. Login to Horizon
3. Browse: Project --> Compute --> Images
4. Click Create Image

Actual results:
===============
Error appears on Create Image wizard:

"The current Horizon settings indicate no valid image creation methods are available. Providing an image location and/or uploading from the local file system must be allowed to support image creation."


Expected results:
=================
No error, user allow to select image source

Additional info:
================
Screenshot is enclosed

Comment 1 Ido Ovadia 2016-10-27 11:55:21 UTC
I was able to create an image from CLI

Comment 2 Radomir Dopieralski 2016-10-28 09:01:31 UTC
Do you have OPENSTACK_IMAGE_FORMATS in the REST_API_REQUIRED_SETTINGS in your local_settings as per http://docs.openstack.org/releasenotes/horizon/newton.html#id3 ?

Comment 3 Radomir Dopieralski 2016-10-31 08:53:32 UTC
Posted a patch to puppet-horizon: https://review.openstack.org/#/c/391754/

Comment 4 Radomir Dopieralski 2016-10-31 13:09:11 UTC
Backported the patch to Newton: https://review.openstack.org/#/c/391825/

Comment 5 Radomir Dopieralski 2016-11-07 08:20:10 UTC
*** Bug 1382007 has been marked as a duplicate of this bug. ***

Comment 7 Ana Krivokapic 2016-11-28 11:19:47 UTC
Works with:

python-django-horizon-10.0.1-3.el7ost.noarch
puppet-horizon-9.4.1-1.el7ost.noarch

Comment 9 errata-xmlrpc 2016-12-14 16:26:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.