Bug 1389327 - cursor permanently hidden by youtube videos in pivoted mode (xwayland bug?)
Summary: cursor permanently hidden by youtube videos in pivoted mode (xwayland bug?)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-10-27 13:01 UTC by Kamil Páral
Modified: 2017-04-11 08:43 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-1.19.3-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 00:25:25 UTC


Attachments (Terms of Use)
bug demonstration video (2.28 MB, application/octet-stream)
2016-10-27 13:02 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2016-10-27 13:01:51 UTC
Description of problem:
I can reliably reproduce a problem where your cursor gets hidden after hovering over youtube videos and does not get displayed anywhere in Firefox (even outside the video area) until you leave the app completely. This only happens on Wayland, and curiously enough, it only seems to happen for monitors in pivoted mode. See the attached video.

Version-Release number of selected component (if applicable):
firefox-49.0-2.fc25.x86_64
gnome-session-wayland-session-3.22.1-2.fc25.x86_64
gnome-shell-3.22.1-2.fc25.x86_64
gtk3-3.22.2-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.i686
libwayland-client-1.12.0-1.fc25.x86_64
libwayland-cursor-1.12.0-1.fc25.x86_64
libwayland-server-1.12.0-1.fc25.i686
libwayland-server-1.12.0-1.fc25.x86_64
mesa-libwayland-egl-12.0.3-3.fc25.x86_64
mutter-3.22.1-5.fc25.x86_64
xorg-x11-server-Xorg-1.19.0-0.2.20160929.fc25.x86_64
xorg-x11-server-Xwayland-1.19.0-0.2.20160929.fc25.x86_64

How reproducible:
always (for my setup)

Steps to Reproduce:
1. have two monitors, the left in landscape mode, the right in pivoted mode (top-aligned, resolutions should not matter)
2. run gnome wayland session
3. run youtube in firefox, make sure a video is playing (it must not be stopped, that doesn't hide the cursor)
4. move the cursor from the left monitor to the video area on the right monitor quickly. The cursor should disappear instantly, and it should not reappear even if you leave the video area and move around in the browser. Try a few times if needed.
5. move the cursor outside of firefox window, the cursor should reappear
6. perform 4) again, but this time slowly, going over a piece of non-video-area firefox window. The cursor should not get hidden immediately (but after a few second delay) and it should reappear immediately after leaving the video area.

Additional info:
This only seems to happen for pivoted monitors (I can't reproduce that with two monitors in landspace mode), and only if you enter the video area quickly enough. I could not reproduce the same problem with totem or vlc.

Comment 1 Kamil Páral 2016-10-27 13:02:22 UTC
Created attachment 1214589 [details]
bug demonstration video

Comment 2 Kamil Páral 2017-03-03 13:07:23 UTC
I still hit this every day. Any chance to fix this soon?

firefox-51.0.1-2.fc25.x86_64
gnome-session-wayland-session-3.22.2-3.fc25.x86_64
gnome-shell-3.22.3-1.fc25.x86_64
gtk3-3.22.9-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.x86_64
libwayland-cursor-1.12.0-1.fc25.x86_64
libwayland-server-1.12.0-1.fc25.x86_64
mesa-libwayland-egl-13.0.4-1.fc25.x86_64
mutter-3.22.3-1.fc25.x86_64
xorg-x11-server-Xorg-1.19.1-3.fc25.x86_64
xorg-x11-server-Xwayland-1.19.1-3.fc25.x86_64

Comment 3 Kamil Páral 2017-03-03 14:38:30 UTC
Olivier Fourdan confirmed he can reproduce this issue even in Weston and even using Google Chrome.

Comment 6 Olivier Fourdan 2017-03-06 14:05:11 UTC
Possible fix: https://patchwork.freedesktop.org/series/20765/

Comment 8 Kamil Páral 2017-03-13 11:40:21 UTC
Thanks, awesome. When there's a build for Fedora, I can easily test this, if preferred.

Comment 9 Fedora Update System 2017-03-30 15:28:47 UTC
xorg-x11-server-1.19.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fae700469f

Comment 10 Fedora Update System 2017-03-31 03:22:58 UTC
xorg-x11-server-1.19.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fae700469f

Comment 11 Fedora Update System 2017-04-01 00:25:25 UTC
xorg-x11-server-1.19.3-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Kamil Páral 2017-04-11 08:43:20 UTC
I can confirm this is fixed. Awesome, thanks Olivier.


Note You need to log in before you can comment on or make changes to this bug.