Bug 138950 - [Documentation] rpm -qi missing from help
[Documentation] rpm -qi missing from help
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-11 20:53 EST by Benny Sun
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 08:20:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benny Sun 2004-11-11 20:53:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
I am a new user to Fedora, but I do remember reading before about the
package info option -qi somewhere. But I checked `rpm --help` for the
proper command and I got:


=======================================================
Query options (with -q or --query):
  -c, --configfiles                list all configuration files
  -d, --docfiles                   list all documentation files
  --dump                           dump basic file information
  -l, --list                       list files in package
  --queryformat=QUERYFORMAT        use the following query format
  -s, --state                      display the states of the listed files
  -a, --all                        query/verify all packages
  -f, --file                       query/verify package(s) owning file
  -g, --group                      query/verify package(s) in group
  -p, --package                    query/verify a package file
  --specfile                       query a spec file
  --whatrequires                   query/verify the package(s) which
require a
                                   dependency
  --whatprovides                   query/verify the package(s) which
provide a
                                   dependency
=======================================================

Nothing about the -i option exists here. A site tells me that `rpm
-qi` displays "package information, including name, version, and
description."

Version-Release number of selected component (if applicable):
rpm-4.3.2-21

How reproducible:
Always

Steps to Reproduce:
1. rpm --help
2.
3.
    

Actual Results:  -i option and its purpose missing from Query Options
section of rpm help

Expected Results:  Should be a blurb about being able to use the -i
option in conjunction with -q.

Additional info:
Comment 1 Jeff Johnson 2004-11-12 08:20:05 EST
The --info long option is in rpmquery --help
  --info          list descriptive information from package(s)

The short -i option cannot be documented in --help because it
has at least 3 different interpretations, depending on context.

Note You need to log in before you can comment on or make changes to this bug.