Bug 1389519 - bodhi-server and bodhi-client don't include the release in their Requires on python2-bodhi
Summary: bodhi-server and bodhi-client don't include the release in their Requires on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bodhi
Version: epel7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Randy Barlow
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1389518
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-27 19:01 UTC by Randy Barlow
Modified: 2017-02-25 02:49 UTC (History)
3 users (show)

Fixed In Version: bodhi-2.3.3-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1389518
Environment:
Last Closed: 2017-02-25 02:49:43 UTC
Type: Bug


Attachments (Terms of Use)

Description Randy Barlow 2016-10-27 19:01:32 UTC
+++ This bug was initially created as a clone of Bug #1389518 +++

Description of problem:
The bodhi-server and bodhi-client subpackages depend on python2-bodhi by version, but not also by release. They should require the releases to match as well. This was causing a "yum upgrade bodhi-server" on staging to upgrade bodhi-server to the 2.3.0-1 build, while leaving the python2-bodhi package at the 2.3.0-0.2.beta build.


Version-Release number of selected component (if applicable):
bodhi-2.3.0-1


How reproducible:
Every time


Steps to Reproduce:
1. Install bodhi-server-2.3.0-0.2.beta.
2. Upgrade to bodhi-server-2.3.0-1.


Actual results:
$ rpm -qa | grep bodhi
python2-bodhi-2.3.0-0.2.beta.9e1c7bab.el7.noarch
bodhi-server-2.3.0-1.el7.noarch


Expected results:
$ rpm -qa | grep bodhi
python2-bodhi-2.3.0-1.el7.noarch
bodhi-server-2.3.0-1.el7.noarch

Comment 1 Fedora Update System 2016-11-01 17:48:40 UTC
bodhi-2.3.1-2.el7, python-fedmsg-atomic-composer-2016.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 2 Fedora Update System 2016-11-30 17:44:05 UTC
bodhi-2.3.1-2.el7 python-fedmsg-atomic-composer-2016.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 3 Fedora Update System 2017-01-13 17:57:15 UTC
bodhi-2.3.1-2.el7 python-fedmsg-atomic-composer-2016.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 4 Fedora Update System 2017-01-14 05:51:23 UTC
bodhi-2.3.3-2.el7, python-fedmsg-atomic-composer-2016.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 5 Fedora Update System 2017-02-01 22:12:56 UTC
bodhi-2.3.3-3.el7 python-fedmsg-atomic-composer-2016.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 6 Fedora Update System 2017-02-02 23:18:41 UTC
bodhi-2.3.3-3.el7, python-fedmsg-atomic-composer-2016.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 7 Fedora Update System 2017-02-06 14:41:36 UTC
bodhi-2.3.3-4.el7 python-fedmsg-atomic-composer-2016.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 8 Fedora Update System 2017-02-07 04:17:52 UTC
bodhi-2.3.3-4.el7, python-fedmsg-atomic-composer-2016.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cd060eeb3c

Comment 9 Fedora Update System 2017-02-25 02:49:43 UTC
bodhi-2.3.3-4.el7, python-fedmsg-atomic-composer-2016.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.