Bug 138958 - removing Firefox 1.0PR before installing 1.0 causes dependency problems
removing Firefox 1.0PR before installing 1.0 causes dependency problems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 00:14 EST by Michael Hughes
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 00:58:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hughes 2004-11-12 00:14:32 EST
Description of problem:

During install of the newer version, a fatal error regarding xpistub
library occurs.  Re-installation of 1.0PR fixes the browser, but still
won't allow 1.0 to install.


Version-Release number of selected component (if applicable):

Firefox 1.0PR and 1.0 


How reproducible:

Unverfied, but this was a new install of core3 that went flawless
until this (one of the first mods I made.)


Steps to Reproduce:
1.  Install core3 with 'Workstation' packages.
2.  Open Firefox and download the specified version
3.  Close Firefox and remove it using the 'Applications >> System
Settings >> Add/Remove Applications' utility.
4.  The system identifies three components that will be removed to
achieve the uninstall (I didn't pay attention to what they
were)...click OK.
5.  Try to install the new version of Firefox 1.0 by browsing the
filesystem and clicking firefox-installer-bin.  

  
Actual results:
After asking where to install and with which components, the error
message appears:

   Fatal Error [-618]: Couldn't open xpistub library



Expected results:
Installation as normal, or resolving of dependencies.

Additional info:
Comment 1 Warren Togami 2004-11-12 00:58:29 EST
Upstream's firefox installer is not our responsibility.  We highly
recommend using only Fedora Project built firefox RPMS.  FC3 updates
currently has firefox-1.0-2.fc3.  Red Hat is actively working further
development for the firefox package beyond the schedule of upstream
Firefox.

Note You need to log in before you can comment on or make changes to this bug.