Bug 138963 - iiimf conflicts with cscope_maps.vim plugin for vim
iiimf conflicts with cscope_maps.vim plugin for vim
Status: CLOSED DUPLICATE of bug 118023
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-11-12 01:36 EST by Luke Huang
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Huang 2004-11-12 01:36:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7)
Gecko/20040616 Firefox/0.9

Description of problem:
using cscope_maps.vim plugin in coding c program, the developer can
find all references to the token under cursor by hitting "CTRL-\ s",
but in Fedora Core 3, if the iiim server was started, hitting "CTRL-\
s" will invoke Chinese pinyin input method instead of show the
references to the token under cursor. I tried run /etc/init.d/iiimf
stop, the finding function of cscope_maps.vim worked again, and
/etc/init.d/iiimf start, the function of cscopt_maps.vim failed. 

BTW: my locale is Chinese UTF-8

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./etc/init.d/iiimf start
2. edit any c file under vim with cscope_maps.vim plugin
3. move cursor to one token
4. press CTRL-\ s, the chinese input method will be invoked 
5. /etc/init.d/iiimf stop
6. edit any c file under vim with cscope_maps.vim plugin
7. move cursor to one token
8. press CTRL-\ s , all reference to this toke will be shown at the
bottom of vim

Additional info:
Comment 1 Luke Huang 2004-11-12 01:40:14 EST
If you don't think it is a bug, could you please tell me how to solve
under my environment. Thanx a lot
Comment 2 Leon Ho 2005-02-22 20:37:05 EST
Same problem as #118023. Please look at that bug's comment #8 and see
if it helps.

*** This bug has been marked as a duplicate of 118023 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.