Bug 138975 - Kernel hangs when logging out of X
Kernel hangs when logging out of X
Status: CLOSED DUPLICATE of bug 138348
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Brian Brock
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-11-12 05:39 EST by Taco Scargo
Modified: 2014-06-18 05:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages x11 crash with radeon module (32.74 KB, text/plain)
2004-11-20 13:55 EST, Uwe Beck
no flags Details
Xorg.0.log dri radeon crash (43.15 KB, text/plain)
2004-11-20 13:58 EST, Uwe Beck
no flags Details
xorg.conf for ATI Radeon 9000 Pro (2.82 KB, text/plain)
2004-11-20 14:01 EST, Uwe Beck
no flags Details

  None (edit)
Description Taco Scargo 2004-11-12 05:39:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
Nov 12 11:30:42 leeuwen gconfd (leeuwen-3403): Exiting
Nov 12 11:30:42 leeuwen gdm(pam_unix)[2981]: session closed for user
leeuwen
Nov 12 11:30:42 leeuwen dbus: avc:  1 AV entries and 1/512 buckets
used, longest  chain length 1
Nov 12 11:30:42 leeuwen kernel: agpgart: Found an AGP 2.0 compliant
device at 00 00:00:00.0.
Nov 12 11:30:42 leeuwen kernel: agpgart: Putting AGP V2 device at
0000:00:00.0 i nto 1x mode
Nov 12 11:30:42 leeuwen kernel: agpgart: Putting AGP V2 device at
0000:01:00.0 i nto 1x mode
Nov 12 11:30:42 leeuwen kernel: Unable to handle kernel paging request
at virtua l address b6a0d937
Nov 12 11:30:42 leeuwen kernel:  printing eip:
Nov 12 11:30:42 leeuwen kernel: c01571c9
Nov 12 11:30:42 leeuwen kernel: *pde = 00000000
Nov 12 11:30:42 leeuwen kernel: Oops: 0000 [#1]
Nov 12 11:30:42 leeuwen kernel: Modules linked in: cisco_ipsec(U)
parport_pc lp parport autofs4 sunrpc ds dm_mod radeon md5 ipv6
yenta_socket pcmcia_core uhci_h cd ehci_hcd snd_intel8x0m snd_intel8x0
snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer
snd_page_alloc snd_mpu401_uart snd_rawmidi snd_seq_device snd
soundcore ipw2100 ieee80211 ieee80211_crypt e1000 floppy ext3 jbd
Nov 12 11:30:42 leeuwen kernel: CPU:    0
Nov 12 11:30:42 leeuwen kernel: EIP:    0060:[<c01571c9>]    Tainted:
P   VLI
Nov 12 11:30:42 leeuwen kernel: EFLAGS: 00213286   (2.6.9-1.648_EL)
Nov 12 11:30:42 leeuwen kernel: EIP is at remove_vm_struct+0x2c/0x12e
Nov 12 11:30:42 leeuwen kernel: eax: 00000000   ebx: b6a0d8fb   ecx:
00000000 edx: ddaf7000
Nov 12 11:30:42 leeuwen kernel: esi: de3e9270   edi: d7a78800   ebp:
dfcafa40 esp: ddaf7e8c
Nov 12 11:30:42 leeuwen kernel: ds: 007b   es: 007b   ss: 0068
Nov 12 11:30:42 leeuwen kernel: Process X (pid: 4072,
threadinfo=ddaf7000 task=d 28fe7f0)
Nov 12 11:30:42 leeuwen kernel: Stack: de3e9078 de3e9270 df762180
c0159481 c03de 0b4 00000777 dfcafa40 dfcafa40
Nov 12 11:30:42 leeuwen kernel:        c011e594 d28fe7f0 c01739e5
00000000 ddaf7 000 df20dc80 dfdc8e00 c0173c9c
Nov 12 11:30:42 leeuwen kernel:        c0173728 ddaf7ed4 00000080
dfdd8880 dfdd8 880 00400000 ffffffb0 00000001
Nov 12 11:30:42 leeuwen kernel: Call Trace:
Nov 12 11:30:42 leeuwen kernel:  [<c0159481>] exit_mmap+0x1dc/0x1e5
Nov 12 11:30:42 leeuwen kernel:  [<c011e594>] mmput+0xb9/0xdc
Nov 12 11:30:42 leeuwen kernel:  [<c01739e5>] exec_mmap+0x2b3/0x2cd
Nov 12 11:30:42 leeuwen kernel:  [<c0173c9c>] flush_old_exec+0x43/0x367
Nov 12 11:30:42 leeuwen kernel:  [<c0173728>] kernel_read+0x31/0x3b
Nov 12 11:30:42 leeuwen kernel:  [<c019a39f>] load_elf_binary+0x4e8/0xb92
Nov 12 11:30:42 leeuwen kernel:  [<c0173265>] copy_strings+0x22b/0x235
Nov 12 11:30:42 leeuwen kernel:  [<c0174e58>]
search_binary_handler+0x6f/0x1ae
Nov 12 11:30:42 leeuwen kernel:  [<c01750ff>] do_execve+0x168/0x1f6
Nov 12 11:30:42 leeuwen kernel:  [<c0104964>] sys_execve+0x2a/0x6f
Nov 12 11:30:42 leeuwen kernel:  [<c030b3c3>] syscall_call+0x7/0xb
Nov 12 11:30:42 leeuwen kernel: Code: 31 c9 ba 5e 00 00 00 56 89 c6 53
8b 78 4c b8 6e c4 31 c0 e8 a2 69 fc ff e8 63 29 1b 00 85 ff 0f 84 d5
00 00 00 8b 9f a0 00  00 00 <81> 7b 3c 3c 4b 24 1d 74 18 8d 43 3c 50
6a 61 68 6e c4 31 c0 68


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up in X, login
2. logout

This is on an IBM X31 laptop

Actual Results:  System hangs (see excerpt from /var/log/messages)

Additional info:
Comment 3 Taco Scargo 2004-11-15 04:39:00 EST
Commenting out dri from xorg.conf makes the problem go away:

#       Load  "dri"
Comment 5 Jay Turner 2004-11-16 06:40:12 EST
Taco, not that I think it's going to make much difference, but you need to
unload whatever is tainting your kernel in order to make it easier to debug the
issue.
Comment 7 Mike A. Harris 2004-11-16 19:09:54 EST
Taco:  The kernel is tainted by unsupported 3rd party kernel modules
as the Oops message indicates, and Jay pointed out in comment #5
above.  Before we can investigate this issue, we need you to remove
the 3rd party modules from your system, and try to reproduce the
problem using our supported kernel with no 3rd party modules.

If the problem is still present, please attach the /var/log/messages
from the latest system bootup onward, as well as the X server log
and config file, as individual uncompressed file attachments, using
the bugzilla link below.

Also, try leaving DRI enabled, but instead disabling render accel
to see if that fixes the issue.  If not, try "noaccel".

Report back your findings and change the bug state from NEEDINFO
to ASSIGNED.

Thanks in advance.
Comment 8 Mike A. Harris 2004-11-18 12:32:06 EST
Please provide the information requested above and update the
report.  Thanks in advance.
Comment 9 Uwe Beck 2004-11-18 13:03:08 EST
I see the same problem with the opensource radeon kernel module.

1. Boot up in X, login, logout and the system hangs. Only a hard reset
helps.
2. Boot in runlevel 3, start the X with "startx". You can logout but
the next "startx hangs" (see only the big X on sscreen). Only a hard
reset helps.

If I comment out dri from xorg.conf
#       Load  "dri"
I can work normal, but the grafic performace is bad.

lspci
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250
If [Radeon 9000] (rev 01)
01:00.1 Display controller: ATI Technologies Inc Radeon RV250 [Radeon
9000] (Secondary) (rev 01)

I do not use 3rd party module from ATI, I use
/lib/modules/2.6.9-1.648_EL/kernel/drivers/char/drm/radeon.ko.

The xorg.conf was created with system-config-display.

This are the first things I see for this problem.

Comment 10 Uwe Beck 2004-11-20 13:55:24 EST
Created attachment 107119 [details]
messages x11 crash with radeon module
Comment 11 Uwe Beck 2004-11-20 13:56:32 EST
Results with kernel version 2.6.9-1.675_EL:

- boot in runlevel 3
- xorg.conf see attachment
  Load  "dri"
- startx
  after first startx X11 works (kde)
- logout kde
- startx
  black screen
- press CTRL-ALT-DEL
  --> logging in messages
- hard reset
Comment 12 Uwe Beck 2004-11-20 13:58:25 EST
Created attachment 107120 [details]
Xorg.0.log dri radeon crash
Comment 13 Uwe Beck 2004-11-20 14:01:00 EST
Created attachment 107121 [details]
xorg.conf for ATI Radeon 9000 Pro

xorg.conf for ATI Radeon 9000 Pro was created with system-config-display
Comment 14 Taco Scargo 2004-11-22 08:49:37 EST
As I have not had access to the laptop with this problem yet, but saw
Uwe Beck report the same problem (without proprietary modules), please
continue fixing the problem. As soon as I have additional information,
I will report it.
Comment 15 Søren Sandmann Pedersen 2004-11-30 17:19:15 EST
Uwe, could you try adding this:

    Option "BusType" "PCI"

to the "Device" section of your "xorg.conf" file? If this makes the
bug go away, it is almost certainly a duplicate of bug 138348.

Thanks
Comment 16 Søren Sandmann Pedersen 2004-12-02 08:42:01 EST
Also, it would be helpful if you could add the full output of 

           "lspci -v"

run as root.
Comment 17 Søren Sandmann Pedersen 2004-12-03 12:16:16 EST
Duping against bug 138348.

Attaching the information to that bug would still be useful.
Comment 18 Søren Sandmann Pedersen 2004-12-03 14:54:56 EST

*** This bug has been marked as a duplicate of 138348 ***
Comment 19 Uwe Beck 2004-12-04 12:08:16 EST
Since I have

Option "BusType" "PCI"

in the "Device" section of "xorg.conf" there was no problems again.

The Radeon 9000/Pro is an agp card.

Here is the full output of "lspci -v", this is an ASUS P4B533
Mainboard, BIOS 1015 with "Detected 2424.243 MHz processor.":

00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host
Bridge (rev11)
        Subsystem: ASUSTeK Computer Inc.: Unknown device 8088
        Flags: bus master, fast devsel, latency 0
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Capabilities: [e4] Vendor Specific Information
        Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP
Bridge (rev 11) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, fast devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000d000-0000dfff
        Memory behind bridge: d6800000-d7efffff
        Prefetchable memory behind bridge: d8000000-efffffff

00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01) (prog-if 00 [UHCI])
        Subsystem: ASUSTeK Computer Inc.: Unknown device 8089
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at b800 [size=32]

00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01) (prog-if 00 [UHCI])
        Subsystem: ASUSTeK Computer Inc.: Unknown device 8089
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at b400 [size=32]

00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01) (prog-if 00 [UHCI])
        Subsystem: ASUSTeK Computer Inc.: Unknown device 8089
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at b000 [size=32]

00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 01) (prog-if 20 [EHCI])
        Subsystem: ASUSTeK Computer Inc.: Unknown device 8089
        Flags: bus master, medium devsel, latency 0, IRQ 10
        Memory at d6000000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] Debug port

00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 81) (prog-if 00
[Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
        I/O behind bridge: 00009000-0000afff
        Memory behind bridge: d4800000-d5ffffff
        Prefetchable memory behind bridge: d7f00000-d7ffffff

00:1f.0 ISA bridge: Intel Corp. 82801DB/DBL (ICH4/ICH4-L) LPC
Interface Bridge (rev 01)
        Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) IDE Controller (rev
01) (prog-if 8a [Master SecP PriP])
        Subsystem: ASUSTeK Computer Inc.: Unknown device 8089
        Flags: bus master, medium devsel, latency 0, IRQ 9
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at f000 [size=16]
        Memory at 20000000 (32-bit, non-prefetchable) [size=1K]

00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 01)
        Subsystem: ASUSTeK Computer Inc.: Unknown device 8089
        Flags: medium devsel, IRQ 11
        I/O ports at e800 [size=32]

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250
If [Radeon9000] (rev 01) (prog-if 00 [VGA])
        Subsystem: Hightech Information System Ltd. RV250 If
[Excalibur Radeon 9000 Pro]
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64,
IRQ 9
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        I/O ports at d800 [size=256]
        Memory at d7000000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at e7fe0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

01:00.1 Display controller: ATI Technologies Inc Radeon RV250 [Radeon
9000] (Secondary) (rev 01)
        Subsystem: Hightech Information System Ltd.: Unknown device 2004
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Memory at d6800000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

02:03.0 Multimedia audio controller: C-Media Electronics Inc CM8738
(rev 10)
        Subsystem: ASUSTeK Computer Inc. CMI8738 6ch-MX
        Flags: bus master, stepping, medium devsel, latency 32, IRQ 5
        I/O ports at a800 [size=256]
        Capabilities: [c0] Power Management version 2

02:0a.0 SCSI storage controller: Adaptec AHA-2940U/UW/D / AIC-7881U
(rev 01)
        Subsystem: Adaptec AHA-2940UW SCSI Host Adapter
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at a400 [disabled] [size=256]
        Memory at d5800000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 1

02:0b.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX
[Cyclone] (rev 24)
        Subsystem: 3Com Corporation 3C905B Fast Etherlink XL 10/100
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at a000 [size=128]
        Memory at d5000000 (32-bit, non-prefetchable) [size=128]
        Capabilities: [dc] Power Management version 1

02:0c.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
        Flags: bus master, medium devsel, latency 32, IRQ 9
        I/O ports at 9800 [size=64]

02:0d.0 Network controller: AVM Audiovisuelles MKTG & Computer System
GmbH Fritz!PCI v2.0 ISDN (rev 02)
        Subsystem: AVM Audiovisuelles MKTG & Computer System GmbH
Fritz!PCI v2.0 ISDN
        Flags: medium devsel, IRQ 5
        Memory at d4800000 (32-bit, non-prefetchable) [size=32]
        I/O ports at 9400 [size=32]
        Capabilities: [40] Power Management version 2

I have no access to bug 138348.
Comment 20 Red Hat Bugzilla 2006-02-21 14:06:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.