Bug 1389772 - inkscape dependencies missing potrace, python-scour
Summary: inkscape dependencies missing potrace, python-scour
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1389784
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-28 14:36 UTC by RudraB
Modified: 2016-11-19 21:04 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-10 15:52:03 UTC


Attachments (Terms of Use)

Description RudraB 2016-10-28 14:36:02 UTC
Description of problem:
In taskbar, under Path, there is a task called "Trace Bitmap". This is missing in 0.92 build of fedora.

Version-Release number of selected component (if applicable):
inkscape-0.92-3.pre2.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open Innkscape
2. Click Path
3. See the dropdown

Actual results:
Trace Bitmap option is missing

Expected results:

Trace Bitmap option should be present.

Additional info:
I have chatted with the developers @irc, and this is what it is(specially read lines between ******):

roddur:  Hi, in inkscape .91, there was a "trace Bitmap" under "Path". Is it moved somewhere, or taken off?
Mc:  roddur: still there
roddur:  Mc, not in version .92
roddur:  at least not in the version packed for fedora 25
Mc:  fedora packed a version already ?
roddur:  yes
*********
Mc:  did they compile it with libpotrace-dev and make inkscape depend on libpotrace ?
***********
roddur:  rpm -q inkscape
inkscape-0.92-3.pre2.fc25.x86_64
Mc:  roddur: how do you report packaging problems to fedora ?

********
Mc:  previously we provided an embedded copy of potrace with the source code
Mc:  but we changed that to use libpotrace as external dependency
Mc:  and if it's not present, then trace bitmap does not work
Mc:  (or paint bucket)
roddur:  ok...it was confusing...because the option is not there in the dropdown menu. 
roddur:  I will rise a bugzilla report
*********
Mc:  it makes it possible to compile inkscape without potrace, and then everything that depends on it is not present, but the intention is to make potrace a dep
Mc: http://wiki.inkscape.org/wiki/index.php/Release_notes/0.92#New_dependencies
Mc:  (you might have the same problem with save as optimized svg -> scour)

Comment 1 Gwyn Ciesla 2016-10-28 15:24:25 UTC
I'll get this out, and submit a review for scour, since it's not in Fedora yet.

Comment 2 Fedora Update System 2016-11-01 18:19:25 UTC
python-scour-0.35-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3565264129

Comment 3 RudraB 2016-11-02 08:30:25 UTC
solves the problem for me.
Downloaded the build for fc25 from bodhi.

Comment 4 Fedora Update System 2016-11-06 01:52:57 UTC
python-scour-0.35-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dfac269ab2

Comment 5 Fedora Update System 2016-11-07 02:22:35 UTC
inkscape-0.92-5.pre2.fc25, python-scour-0.35-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cc91f59804

Comment 6 Fedora Update System 2016-11-10 15:52:03 UTC
python-scour-0.35-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2016-11-14 20:58:53 UTC
python-scour-0.35-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2016-11-19 21:04:06 UTC
inkscape-0.92-5.pre2.fc25, python-scour-0.35-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.