Bug 138983 - httpd, path=/usr/lib/libsasl2.so.2.0.20 denied
httpd, path=/usr/lib/libsasl2.so.2.0.20 denied
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 07:02 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 10:27:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-11-12 07:02:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041109 Firefox/1.0

Description of problem:
Stopping httpd:                                            [FAILED]
Starting httpd: /usr/sbin/httpd: error while loading shared libraries:
libsasl2.so.2: failed to map segment from shared object: Permission denied
                                                           [FAILED]

audit(1100261096.078:0): avc:  denied  { execute } for  pid=3688
path=/usr/lib/libsasl2.so.2.0.20 dev=dm-0 ino=1140183
scontext=root:system_r:httpd_t tcontext=root:object_r:lib_t tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.19.1-2

How reproducible:
Always

Steps to Reproduce:
1. See summary.
    

Additional info:
Comment 1 Daniel Walsh 2004-11-12 07:29:34 EST
restorecon /usr/lib/libsasl2.so.2.0.20
Should be shlib_t

Some how the context got screwed up.
Comment 2 Ivan Gyurdiev 2004-11-12 10:27:45 EST
[root@cobra ~]# restorecon /usr/lib/libsasl2.so.2.0.20
[root@cobra ~]# ls -Z /usr/lib/libsasl2.so.2.0.20
-rwxr-xr-x  root     root     system_u:object_r:shlib_t       
/usr/lib/libsasl2.so.2.0.20
[root@cobra ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd:                                            [  OK  ]
[root@cobra ~]#

Closing bug. Still, that's strange. 
Comment 3 Daniel Walsh 2004-11-12 10:32:12 EST
Any chance RPM screwed up?  Did you boot with selinux=0?

Dan
Comment 4 Ivan Gyurdiev 2004-11-12 11:35:43 EST
No, but I might have turned it off temporarily, and then back on.
I don't think I was installing RPMs at the time though.

SElinux was complaining bout my attempt to install 
a subversion server and use that with viewcvs. I gave up
on it eventually since svn+ssh wasn't working anyway.



Note You need to log in before you can comment on or make changes to this bug.