Bug 138986 - some toolbar icons are broken
Summary: some toolbar icons are broken
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Marco Pesenti Gritti
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-12 12:08 UTC by Enrico Scholz
Modified: 2018-04-11 06:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 16:47:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
right-click on toolbar --> Customize (18.96 KB, image/png)
2004-11-12 12:09 UTC, Enrico Scholz
no flags Details
Screenshot of current FC4 Firefox icons (314.78 KB, image/png)
2005-05-20 03:52 UTC, Sean Earp
no flags Details
Default theme file for Firefox 1.0.4 (500.89 KB, application/x-jar)
2005-06-19 03:24 UTC, Jared Sutton
no flags Details
Padlock icon missing (79.35 KB, image/png)
2005-09-22 21:37 UTC, Marcin Garski
no flags Details

Description Enrico Scholz 2004-11-12 12:08:16 UTC
Description of problem:

some toolbar icons are broken:
- history, bookmarks, chromedit, download are invisible/non existing
- 'open new tab' has the same color like the background and only a
  few lines are visible


Version-Release number of selected component (if applicable):

firefox-1.0-1

Comment 1 Enrico Scholz 2004-11-12 12:09:34 UTC
Created attachment 106559 [details]
right-click on toolbar  -->  Customize

Comment 2 Enrico Scholz 2005-04-19 11:41:13 UTC
ping...

still with firefox-1.0.3-2


Comment 3 Sean Earp 2005-05-20 03:50:22 UTC
I can confirm this problem as well.  History, bookmarks, and download are all
missing when you attempt to customize the toolbar.

As well, the default Firefox toolbar icons (which Themes SAYS is the default
Firefox 2.0 Theme set) is definitely NOT the default theme set.  The icons in
the current Rawhide firefox are plug-ugly, and do not match the default firefox
icons that are present on my Windows box, my Mac, and FC2 (those all match each
other).  I'm not sure what these icons are, but they need to be replaced by the
correct default firefox icons.  Thanks!

-Sean

Comment 4 Sean Earp 2005-05-20 03:52:33 UTC
Created attachment 114609 [details]
Screenshot of current FC4 Firefox icons

Comment 5 Christopher Aillon 2005-06-06 18:23:58 UTC
Known issue.  But its a very low priorty right now since its not a common task
and doesn't affect the default toolbar.

Comment 6 Marco Pesenti Gritti 2005-06-06 18:43:53 UTC
This is a simple fix I think. I actually had a patch for it at some point...
Will try to find the time to get this fixed soon.

Comment 7 Jared Sutton 2005-06-19 03:24:24 UTC
Created attachment 115660 [details]
Default theme file for Firefox 1.0.4

I too dislike the default toolbar theme in FC4.  It may match some default
Gnome theme, but it looks terrible in a KDE environment.  If you want the
(real) default Firefox theme back, copy the classic.jar file that I'm attaching
to this to /usr/lib/firefox-1.0.4/chrome.

I pulled this version of the file from a Firefox 1.0.4 RPM for FC3.

Comment 8 Marcin Garski 2005-09-22 21:36:07 UTC
"But its a very low priorty right now since its not a common task
and doesn't affect the default toolbar."

It affect the default toolbar see bug #138886 also please look at my screenshot,
padlock icon is missing! It should't be low priorty it should be high.

Firefox 1.0.6-1.2.fc4

Comment 9 Marcin Garski 2005-09-22 21:37:53 UTC
Created attachment 119167 [details]
Padlock icon missing

Comment 10 Jared Sutton 2005-12-22 16:21:43 UTC
This still seems to be a problem with Firefox 1.0.7-1.1.fc4.  Might be something
nice to address in before FC5 is released...

Comment 11 Enrico Scholz 2005-12-22 17:04:37 UTC
FWIW, firefox-1.5 has nice icons again instead of the butt-ugly ones from
firefox-1.0.7. This solves the toolbar icon problem, too.

Thx for this nice work

Comment 12 Matěj Cepl 2007-12-20 16:47:56 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.