Bug 138993 - Right click on misspelled word causes OpenOffice to crash.
Right click on misspelled word causes OpenOffice to crash.
Status: CLOSED DUPLICATE of bug 124374
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: 140583
  Show dependency treegraph
 
Reported: 2004-11-12 07:39 EST by Nathan Aaron
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 11:08:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Aaron 2004-11-12 07:39:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When right clicking on a mispelled(red squigly line under it) word
OpenOffice starts consuming large amounts of memorry and processor and
eventually crashes.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-11.5.fc3

How reproducible:
Always

Steps to Reproduce:
1. Mispell a word
2. Wait for red line to appear underneath
3. Right click on the word
    

Actual Results:  OpenOffice Crashed

Expected Results:  A menu with the spell check option should apear of
the word.

Additional info:

This a fresh load of Fedora Core 3.  I have run up2date.  This is also
an AMD Athlon T-Bird 1GHz processor.
Comment 1 Gene Wilson 2004-11-13 14:04:51 EST
I'm seeing this too, no crash but 100% CPU usage until I kill it. 
This happens everytime and makes OO pretty hard to use.  Contextual
spell checking has always been slow in OO but this is much worse.
I'm running a PIII 700Mhz with 256M of RAM on an upgrade from FC2 to FC3
Comment 2 Daniel Thompson 2004-11-16 04:08:49 EST
I also found this problem.

From the system monitor panel applet it appears to be allocating
*vast* ammounts of memory in order to do the contextual lookup. For
three letter words it manages to make a suggestion after 'only' a
minute or so while only just touching swap. For longer words I have
seen it eat memory until the OOM killer spewed messages onto the console.

I have 512MB RAM, 2G swap and am running a fairly old install; my
machines upgrade path is RH9->FC1->FC2->FC3.

Although I first observed the problem in 1.1.2-11.5.fc3 I have tried
the following experiments without success:
 - reinstall 1.1.2-10 from the original ISOs,
 - try as a freshly created user (with a clean home directory).

I have not observed this problem on any FC2 machines (1.1.2-11.4.fc2)
though these are different machines. I still have an image of the disk
of a machine that fails under FC3. This means I could try
1.1.2-11-4.fc2 (under FC2) on a machine known to fail on FC3. However
this would be a significant effort so I'll only do this if requested
to by the assignee.
Comment 3 Gilboa Davara 2004-11-16 13:17:28 EST
Same here. oowriter doesn't crash, it just hangs with very high CPU
usage. However, after a minute or two, oowriter goes back to normal.
(I found that by frantically right clicking I can sometimes release it
faster)

OS: FC3 upgraded from FC2.
Machine: 2xMP2400, 1GB, 4GB SWAP, RAID5 SCSI.
OO Version: openoffice.org-1.1.2-11.5.fc3, 

Gilboa



Comment 4 Fabrice FRANCOIS 2004-11-16 16:01:08 EST
I had the same issue and I managed to fix it. The dictionaries
installed with ooo are too numerous. I erased the superfluous
dictionaries in /usr/lib/ooo-1.1/share/dict/ooo/ and I have no more
problem now.

Fabrice.
Comment 5 Len Trigg 2004-11-17 17:22:28 EST
I have the same problem here, using 1.1.2-11.4.fc2. The problem does
not occur with a 1.1.3 downloaded directly from OO.org.

Initial memory use on my machine after opening a doc:
VIRT=156m RES=70m

Right click on a misspelling...
VIRT=392m RES=228m

Right click on another misspelling and memory goes up again (I killed
it after 500m).  This is pretty serious (my machine is basically
unusable while OO is swapping on my poor laptop).  I will try
Fabrice's workaround.
Comment 6 Fabrice FRANCOIS 2004-11-17 19:35:54 EST
Many entries are duplicated in
/usr/lib/ooo-1.1/share/dict/ooo/dictionary.lst :
$ cd /usr/lib/ooo-1.1/share/dict/ooo
$ cat dictionary.lst | wc -l
83
$ cat dictionary.lst | sort | uniq |  wc -l
53
(little) improvement :
# mv dictionary.lst dictionary.lst.orig
# cat dictionary.lst.orig | sort | uniq > dictionary.lst

Fabrice.
Comment 7 Fabrice FRANCOIS 2004-11-17 21:08:04 EST
Sorry, I forgot to mention the most important :
* Fresh install of Fedora Core 3
* mobile AMD Duron 1Ghz 256M RAM
* openoffice.org-1.1.2-11.5.fc3

Apologies,
Fabrice.
Comment 8 Gilboa Davara 2004-11-23 15:46:14 EST
Using sort and unique to remove duplicate lines (as Fabrice pointed
out) seem to have solved the problem.

Gilboa
Comment 9 Féliciano Matias 2004-11-24 20:01:12 EST
Fabrice workaround (fix ?, comment #6 ) works here.
* Fresh install of FC3
* openoffice.org-1.1.2-11.5.fc3
Comment 10 Nathan Aaron 2004-11-24 20:41:45 EST
Fabrice's workaround helped.  It doesn't crash now.  It only grinds
for an extended period.

Nathan
Comment 11 xavier.loup 2004-11-25 05:01:23 EST
With all dictionaries, the computer freezed. I had to reboot.
After removing every dictionary but the 2 i need (dictionary.lst), the
response time is perfect.
Comment 12 Matt Britt 2004-11-29 11:52:47 EST
I confirm this bug. For me OOo will simply eat up every bit of
available memory (about 450 MiB) and swap until I kill it.  If I let
it alone long enough it will eventually come back.  Fabrice's
workaround helps; deleting the extra dictionaries helps more.
Comment 13 Dan Williams 2004-11-29 21:42:18 EST

*** This bug has been marked as a duplicate of 124374 ***

Note You need to log in before you can comment on or make changes to this bug.