Bug 1389987 - neutron-db-manage fails with: oslo_db.exception.DBError: (pymysql.err.InternalError) (1067, u"Invalid default value for 'created_at'") [SQL: u"\nCREATE TABLE opendaylightjournal_new (\n\tseqnum BIGINT NOT NULL AUTO_INCREMENT, \n\tobject_type VARCHAR(36) N
Summary: neutron-db-manage fails with: oslo_db.exception.DBError: (pymysql.err.Interna...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Mike Kolesnik
QA Contact: Itzik Brown
URL:
Whiteboard:
: 1390317 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-30 11:21 UTC by Marius Cornea
Modified: 2018-10-18 07:18 UTC (History)
11 users (show)

Fixed In Version: python-networking-odl-2.0.1-1.3.264292dgit.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2016-12-14 16:26:32 UTC


Attachments (Terms of Use)
error log of deployment failure (88.82 KB, text/plain)
2016-10-31 07:56 UTC, Ronnie Rasouli
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 391283 None None None 2016-10-30 11:21:37 UTC
Launchpad 1637272 None None None 2016-10-30 11:22:44 UTC

Description Marius Cornea 2016-10-30 11:21:38 UTC
Description of problem:
Deployment fails during neutron-db-manage step:

 Error: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: Failed to call refresh: neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini upgrade heads returned 1 instead of one of [0]
10:59:43     Error: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: neutron-db-manage --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini upgrade heads returned 1 instead of one of [0]

Trying to run the command manually on the nodes I see the following error:

oslo_db.exception.DBError: (pymysql.err.InternalError) (1067, u"Invalid default value for 'created_at'") [SQL: u"\nCREATE TABLE opendaylightjournal_new (\n\tseqnum BIGINT NOT NULL AUTO_INCREMENT, \n\tobject_type VARCHAR(36) NOT NULL, \n\tobject_uuid VARCHAR(36) NOT NULL, \n\toperation VARCHAR(36) NOT NULL, \n\tdata BLOB, \n\tstate ENUM('pending','processing','failed','completed') NOT NULL, \n\tretry_count INTEGER, \n\tcreated_at DATETIME DEFAULT now(), \n\tlast_retried TIMESTAMP NULL DEFAULT now(), \n\tPRIMARY KEY (seqnum)\n)ENGINE=InnoDB\n\n"]


Version-Release number of selected component (if applicable):
python-neutron-tests-9.0.0-1.5.el7ost.noarch
openstack-neutron-openvswitch-9.0.0-1.5.el7ost.noarch
openstack-neutron-metering-agent-9.0.0-1.5.el7ost.noarch
openstack-neutron-bigswitch-agent-7.0.5-0.20161015221623.f83c499.el7ost.noarch
openstack-neutron-ml2-9.0.0-1.5.el7ost.noarch
python-neutronclient-6.0.0-1.1.el7ost.noarch
python-neutron-lib-0.4.0-1.el7ost.noarch
openstack-neutron-common-9.0.0-1.5.el7ost.noarch
openstack-neutron-bigswitch-lldp-7.0.5-0.20161015221623.f83c499.el7ost.noarch
openstack-neutron-lbaas-9.0.0-2.el7ost.noarch
python-neutron-9.0.0-1.5.el7ost.noarch
python-neutron-lbaas-9.0.0-2.el7ost.noarch
openstack-neutron-9.0.0-1.5.el7ost.noarch
openstack-neutron-sriov-nic-agent-9.0.0-1.5.el7ost.noarch
puppet-neutron-9.4.0-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with composable roles

Actual results:
Deployment fails in neutron-db-manage step

Expected results:
Deployment doesn't fail. 

Additional info:
After applying this patch: https://review.openstack.org/#/c/391283/ neutron-db-manage completed successfully.

Comment 1 Assaf Muller 2016-10-30 17:40:24 UTC
Looks like a backport request for https://review.openstack.org/#/c/391283/ essentially.

Comment 2 Assaf Muller 2016-10-30 17:41:46 UTC
Making sure you see this Mike.

Comment 3 Ronnie Rasouli 2016-10-31 07:56:10 UTC
Did RHOS10 deployment of 1 controller, 2 compute, 1 CEPH no composable  roles at all. 

| AllNodesDeploySteps                       | 33d59502-1654-4909-8bf2-7e4a3461c652         | OS::TripleO::PostDeploySteps                    | CREATE_FAILED   | 2016-10-30T07:51:05Z |

Attached deployment error log

Comment 4 Ronnie Rasouli 2016-10-31 07:56:55 UTC
Created attachment 1215700 [details]
error log of deployment failure

Comment 5 Mike Kolesnik 2016-10-31 09:19:51 UTC
What version of python-networking-odl is used here?

How are you deploying? RHOS Director?

Comment 6 Marius Cornea 2016-10-31 09:21:27 UTC
(In reply to Mike Kolesnik from comment #5)
> What version of python-networking-odl is used here?

python-networking-odl-2.0.1-1.2.f95b320git.el7ost.noarch

> How are you deploying? RHOS Director?

Yes, with Director.

Comment 7 Mike Kolesnik 2016-10-31 09:28:40 UTC
Jon it seems a new build of the driver is needed with the aforementioned patch in it.

Comment 10 Marios Andreou 2016-10-31 17:44:11 UTC
*** Bug 1390317 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2016-12-14 16:26:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.