Bug 1389999 - RabbitMQ url is incorrectly set in proxy-server.conf when deploying composable roles
Summary: RabbitMQ url is incorrectly set in proxy-server.conf when deploying composabl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Steven Hardy
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1390284 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-30 15:07 UTC by Marius Cornea
Modified: 2016-12-29 16:55 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.4.el7ost puppet-tripleo-5.3.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:26:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 393770 None None None 2016-11-07 11:37:24 UTC
OpenStack gerrit 394052 None None None 2016-11-07 11:37:05 UTC

Description Marius Cornea 2016-10-30 15:07:13 UTC
Description of problem:
RabbitMQ url is incorrectly set in proxy-server.conf when deploying composable roles.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.9.0rc3.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud
source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates/

openstack overcloud deploy --templates $THT \
-r ~/openstack_deployment/roles/roles_data.yaml \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e $THT/environments/storage-environment.yaml \
-e $THT/environments/tls-endpoints-public-ip.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/public_vip.yaml \
-e ~/openstack_deployment/environments/enable-tls.yaml \
-e ~/openstack_deployment/environments/inject-trust-anchor.yaml \
-e ~/openstack_deployment/environments/scheduler_hints_env.yaml \
-e ~/openstack_deployment/environments/ips-from-pool-all.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml \
--log-file overcloud_deployment.log &> overcloud_install.log

Actual results:
/etc/swift/proxy-server.conf on the ServiceApi role nodes gets configured with the ip address of the local node instead of the ip addresses of the controller nodes where the rabbitmq services is running:

[root@api-r01-01 ~]# grep rabbit /etc/swift/proxy-server.conf 
url = rabbit://guest:GtnJqaPQzNR8udmX29fe3XKAP@10.0.0.14:5672//
[root@api-r01-01 ~]# ip a | grep 10.0.0.14
    inet 10.0.0.14/25 brd 10.0.0.127 scope global vlan200
[root@api-r01-01 ~]# grep '10.0.0.14 ' /etc/hosts
10.0.0.14 api-r01-01.redhat.local api-r01-01
10.0.0.14 api-r01-01.internalapi.redhat.local api-r01-01.internalapi


Expected results:
The rabbitmq url contains the IP addresses of the controller nodes where the rabbitmq service is binding.

Additional info:

Comment 1 Marius Cornea 2016-10-30 15:10:00 UTC
Environment files:
http://paste.openstack.org/show/587393/

Comment 2 Emilien Macchi 2016-10-31 16:00:35 UTC
*** Bug 1390284 has been marked as a duplicate of this bug. ***

Comment 3 Marius Cornea 2016-10-31 17:36:15 UTC
I tested the attached patches on my environment and I couldn't reproduce the initial issue anymore.

Comment 6 Marius Cornea 2016-11-11 11:23:23 UTC
[root@overcloud-serviceapi-1 ~]# grep rabbit /etc/swift/proxy-server.conf 
url = rabbit://guest:qs6Tg2FubbQAeVNKsddrBkK89@10.0.0.15:5672,guest:qs6Tg2FubbQAeVNKsddrBkK89@10.0.0.20:5672,guest:qs6Tg2FubbQAeVNKsddrBkK89@10.0.0.23:5672//

Comment 8 errata-xmlrpc 2016-12-14 16:26:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.