Bug 139001 - Failure to start any gnome application
Failure to start any gnome application
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 08:56 EST by Joachim Sauer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 09:26:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
prelink log from the time before the problem occured (56.53 KB, text/plain)
2004-11-12 09:21 EST, Joachim Sauer
no flags Details

  None (edit)
Description Joachim Sauer 2004-11-12 08:56:06 EST
Description of problem:
Gnome applications stoped working today for no apparent reason. Only
updated packages where iptable (nothing gnome-related).

After I run "prelink -u -a" the problem vanished. (Sadly re-prelinking
didn't make the problem re-appear so I can't reproduce it now).

Version-Release number of selected component (if applicable):
prelink 0.3.2-11

How reproducible:

Steps to Reproduce:
0. unkown, but probably involves prelink
1. try to run any gnome-application (gnome-about for example)
  
Actual results:
Gnome about dialog pops up

Expected results:
no user-visible action is taken, shell returns to prompt without any
message after some time (varies, some programs return immediatly, some
take 2-3 secconds to return)

Additional info:
Additional Info (+ a stack trace) can be found at
http://bugzilla.gnome.org/show_bug.cgi?id=156627
Comment 1 Jakub Jelinek 2004-11-12 09:01:29 EST
I guess you haven't saved the binary and all dependent libraries before unprelinking, right?
In that case there is probably nothing that can be done about this bugreport.
It might be a bug in one of the libraries that only shows up in certain memory
layouts, etc.  But without a reproducer we are out of luck.
Comment 2 Joachim Sauer 2004-11-12 09:21:22 EST
Created attachment 106564 [details]
prelink log from the time before the problem occured

Thanks for the fast response.

No, I didn't think of that, I'll remember it if I stumble into that kind of
problem again.

I just wanted to ask if logging all prelink invocations would help when I
realized there's a prelink.log in /var/log from today 10:18 (that's about the
time the problems started.

I'm not an expert with prelinking, but does prelink log enough information to
reproduce the setup? Then the log could help ... I'm attaching it in case it
helps.

If it doesn't help ... well, then I'll reopen the bug in case i'm hit by it
again.
Comment 3 Jakub Jelinek 2004-11-12 09:26:07 EST
No, it is impossible to reproduce it from that info.
prelink randomizes, so unless you tell it a specific random seed you will never
be able to recreate the exact same state.

Closing as WONTFIX, since without reproducing it there is nothing further that
can be done.

Note You need to log in before you can comment on or make changes to this bug.