Bug 139002 - Should mdadm obsolete raidtools?
Should mdadm obsolete raidtools?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-11-12 09:03 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-13 11:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-11-12 09:03:19 EST
After upgrading an FC2 machine (that does not use RAID) to FC3, I
noticed that the obsolete raidtools package stayed (and dmraid was not
installed). Is this normal? Or should dmraid be marked as obsoleting
raidtools?
Comment 1 Heinz Mauelshagen 2004-11-12 09:31:34 EST
Obsolete raidtools and dmraid are mostly unrelated.

dmraid activates ATARAID devices on FC3 whereas
raidtools were dealing with MDs (use mdadm now).



Comment 2 Aleksey Nogin 2004-11-12 09:34:54 EST
Does this mean that mdadm should obsolete raidtools?
Comment 3 Heinz Mauelshagen 2004-11-12 09:56:16 EST
mdadm is the newer tool implementation by the RAID
maintainer Neil Brown. There hasn't been any development
in raidtools for a while.

Yes, mdadm obsoletes raidtools in FC3.
Comment 4 Aleksey Nogin 2004-11-12 10:05:28 EST
> Yes, mdadm obsoletes raidtools in FC3.

Well, then I guess it's a bug, because it does not.

% rpm -q mdadm
mdadm-1.6.0-2
% rpm -q --obsoletes mdadm
mdctl
Comment 5 Doug Ledford 2004-11-26 08:50:58 EST
I would prefer not to obsolete raidtools just yet.  There are
dependancies in initscripts related to raidtools and starting devices.
 These *should* be solved already, but I don't want to risk breaking
things in FC3.  Instead, I'll rebuild the package for FC4 with the
obsoletes in place so that if there are any problems with upgrades,
etc. then they can be sorted out during the alpha/beta timeframe.
Comment 6 Doug Ledford 2005-05-13 11:16:48 EDT
An obsoletes for raidtools has been added as of 1.9.0-4.fc4

Note You need to log in before you can comment on or make changes to this bug.