Bug 1390027 - Anaconda should tell the user it is running fsck, possibly allow to skip
Summary: Anaconda should tell the user it is running fsck, possibly allow to skip
Status: CLOSED DUPLICATE of bug 1170803
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker RejectedFreezeException
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-30 23:08 UTC by Charles R. Anderson
Modified: 2016-11-15 20:03 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-07 18:46:10 UTC


Attachments (Terms of Use)

Description Charles R. Anderson 2016-10-30 23:08:32 UTC
Description of problem:

Anaconda appears to run fsck on every detected partition, but there is no notification to the user that fsck is running.  fsck can take a very long time.  There should be some kind of notification and preferably a progress bar when running fsck.  Ideally there should be a way to "skip" fsck on some partitions if you 1) know you are going to wipe them anyway, or 2) are not going to mount them or install to them. 

Version-Release number of selected component (if applicable):
25.20.5-1.fc25

How reproducible:
always

Steps to Reproduce:
1. boot Live, run liveinst
2. click Continue on language select screen
3. acknowledge pre-release warning

Actual results:
Anaconda window dims but there is no notification, dialog, or pop up.  It appears to be hung.


Expected results:
Some kind of notification of what is happening.

Additional info:
e2fsck is still running after 20 minutes on a 2.4TiB hard disk partition

Comment 1 Charles R. Anderson 2016-11-02 05:34:27 UTC
In the end, the e2fsck took over 7.5 hours.  There needs to be a way to skip this...

Comment 2 Charles R. Anderson 2016-11-02 05:54:39 UTC
Proposed as a Blocker for 25-final because I think it violates these criteria:

Package and installer sources https://fedoraproject.org/wiki/Fedora_25_Alpha_Release_Criteria#initialization-requirements

Disk selection

The user must be able to select which of the disks connected to the system will be affected by the installation process.
Other disks not touched [show]
References [show]

(fsck is being performed on all partitions before disk selection is done)

Also, while there is no specific criteria relating to how long it takes to perform an install, I think forcing users to wait 7.5 hours to fsck a filesystem before the install can proceed is worthy of discussion as to whether this should be a Blocker.

Comment 3 Charles R. Anderson 2016-11-02 06:27:40 UTC
See also bug #1162215 and bug #1170803.  The latter bug points out in Comment 30:

Eric Sandeen 2014-12-10 10:20:22 EST

I've sent a patch upstream to drop the fsck requirement if we're only printing the minimum size.

So it seems like the forced fsck should just be dropped from blivet now.

Comment 4 Adam Williamson 2016-11-07 18:46:10 UTC
This is in fact simply a dupe of #1170803 , which was never properly fixed. The e2fsprogs change that meant anaconda/blivet would no longer be required to run e2fsck prior to getting the minimum size was made. An update which applied that change was sent to F22 and marked as fixing #1170803 , pushed stable, and the bug was closed - but of course that alone did not actually fix the bug, because anaconda/blivet still had to be changed. And it never was. So this bug has remained all along.

*** This bug has been marked as a duplicate of bug 1170803 ***

Comment 5 Geoffrey Marr 2016-11-08 00:39:40 UTC
Discussed during the 2016-11-07 blocker review meeting: [1]

The decision to classify this bug as a RejectedBlocker and a RejectedFreezeException was made as this is an issue that has been around since Fedora 21 and has not blocked since. Though we note it causes e2fsck to perform 'safe' fixes on non-selected filesystems, as well as taking a long time if large ext2/3/4 filesystems are present, we don't see sufficient reason to change that decision or change this as an FE at this time.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-11-07/f25-blocker-review.2016-11-07-17.01.txt


Note You need to log in before you can comment on or make changes to this bug.