Bug 139004 - psqlodbc crashes on connection attempt on x86_64.
psqlodbc crashes on connection attempt on x86_64.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: postgresql-odbc (Show other bugs)
3
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Tom Lane
http://gborg.postgresql.org/project/p...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 09:28 EST by Rubin Simons
Modified: 2013-07-02 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-154
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 08:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rubin Simons 2004-11-12 09:28:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.2) Gecko/20040825 Camino/0.8.1

Description of problem:
/usr/lib64/psqlodbc.so seems to crash when invoked. Using unixODBCs
native (but seriously outdated) pgsql driver works using the same
config files (odbc.ini and odbcinst.ini)

I'm running on amd64 and a quick search around returned the following:
http://gborg.postgresql.org/project/psqlodbc/bugs/bugupdate.php?809

Apperently this is something that has to do with 64bit cleanliness and
its been fixed since version 07.05.0001. 

ftp://ftp.postgresql.org/pub/odbc/versions/snapshots/src/psqlodbc-07.05.0001.tar.gz

Ofcourse, I tried it myself already and indeed, using 07.05.0001
alllows you to actually use psqlodbc.so ;-)

Version-Release number of selected component (if applicable):
postgresql-odbc-7.3-8

How reproducible:
Always

Steps to Reproduce:
1. setup /etc/odbcinst.ini to use psqlodbc.so
2. run "isql MyDSN auser foopass"

    

Actual Results:  Segmentation Fault

Expected Results:  You should see an interactive isql shell

Additional info:
Comment 1 Tom Lane 2004-11-12 23:23:23 EST
Since 07.05.0001 isn't a stable release but just a snapshot, I'm hesitant to adopt it in toto.  
But I've extracted the 64-bit fixes from it and built a postgresql-odbc-7.3-9 that seems to 
fix the problem --- leastwise it can connect and do simple queries on x86_64.

I'm still unclear on the procedure for pushing out errata in past Fedora releases :-( but will 
try to make that happen soon.
Comment 2 Rubin Simons 2004-11-23 07:56:31 EST
Is this package in updates-testing yet? Else I can't install it to
test for you. Else, if you can, mail me the srpm so I can test for you
without the need to get it into updates-testing?

Greets,

Rubin.
Comment 5 Tom Lane 2004-12-09 12:30:01 EST
Fix is pushed out for FC2 and FC3 --- sorry about the delay.

Leaving bug open since I still need to make errata for RHEL3 and
RHEL4.
Comment 6 Tom Lane 2005-02-11 21:18:11 EST
Fix is queued for RHEL4 U1.
Comment 7 Tim Powers 2005-06-09 08:45:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-154.html

Note You need to log in before you can comment on or make changes to this bug.