Bug 1390070 - Ephemeral ports are not open in compute firewall thus breaking live migration
Summary: Ephemeral ports are not open in compute firewall thus breaking live migration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Sven Anderson
QA Contact: Gabriel Szasz
URL:
Whiteboard:
: 1393135 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-31 07:38 UTC by Marius Cornea
Modified: 2016-12-14 16:27 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-1.4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:27:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 391876 None None None 2016-10-31 15:03:59 UTC
OpenStack gerrit 394015 None None None 2016-11-07 15:32:56 UTC

Description Marius Cornea 2016-10-31 07:38:10 UTC
Description of problem:
Ephemeral ports are not open in compute firewall thus breaking live migration. Live migration fails with:

Live Migration failure: unable to connect to server at 'comp-r00-01.redhat.local:49152': No route to host

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.9.0rc3.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud with 2 computes, launch an instance
2. Try to live migrate it to the other node

Actual results:
Live migration fails.

Expected results:
Live migration succeeds.

Additional info:
According to the docs we need the ephemeral ports(49152-49215) to be opened on the compute node:

https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/paged/migrating-instances/chapter-1-how-to-migrate-a-live-instance

Comment 2 Sven Anderson 2016-11-07 16:30:24 UTC
Merged in stable/newton. Next rebased build will include it.

Comment 7 Stephen Gordon 2016-11-17 13:36:08 UTC
*** Bug 1393135 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2016-12-14 16:27:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.