Bug 139012 - Upgrade fails if /usr/bin/firefox is a directory
Upgrade fails if /usr/bin/firefox is a directory
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 10:09 EST by Steve Hill
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 10:42:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2004-11-12 10:09:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
My (Fedora Core 2) machines all have FireFox installed in a
_directory_ called /usr/bin/firefox.  Upgrading them to Fedora Core 3
fails mid-upgrade when it tries to replace the existing
/usr/bin/firefox directory with the contents of the
firefox-0.10.1-1.0PR1.20 RPM.  It gives no opportunity to skip
installation of the RPM and continue.

Version-Release number of selected component (if applicable):
Fedora Core 3

How reproducible:
Always

Steps to Reproduce:
1. Install FireFox in a directory called /usr/bin/firefox
2. Upgrade to Fedora Core 3
3.
    

Actual Results:  Installation failed half way through the upgrade and
required me to reboot the system with no indication as to the cause. 
I had to remove /usr/bin/firefox manually and re-run the upgrade.

Expected Results:  1. Detect the problem before installation starts
or 2. Warn about the failed RPM installation but allow the upgrade to
be continued anyway.
or 3. (re)move the /usr/bin/firefox directory during the installation
of the RPM.

It seems that it should be more important to complete the upgrade,
even if firefox hasn't been installed successfully rather than force
the upgrade to be terminated half way through the process.

Additional info:
Comment 1 Jeremy Katz 2004-11-12 10:42:10 EST
Don't do that then.

rpm doesn't support going from something being a directory to a
regular file or a symlink due to a number of race conditions that
result trying to do this.  anaconda assumes that your system is
relatively "correct" before doing an ugprade and having
/usr/bin/firefox as a directory just doesn't fall into that category.
Comment 2 Steve Hill 2004-11-12 10:50:41 EST
Should Anaconda not give you the option to skip the RPM causing the
problem and continue the upgrade anyway?  A system is going to be a
lot more broken after the upgrade aborts half way through then if the
firefox RPM just never installed properly.

Note You need to log in before you can comment on or make changes to this bug.