Bug 139023 - ATI 9100 with Dell 2000FP Digital does not work
ATI 9100 with Dell 2000FP Digital does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2004-11-12 11:11 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 17:23:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log for DVI (42.52 KB, text/plain)
2004-11-12 11:12 EST, Gene Czarcinski
no flags Details
/etc/X11/xorg.conf for DVI (2.84 KB, text/plain)
2004-11-12 11:12 EST, Gene Czarcinski
no flags Details
startx messages for DVI (3.40 KB, text/plain)
2004-11-12 11:13 EST, Gene Czarcinski
no flags Details
/var/log/Xorg.0.log for analog video (43.82 KB, text/plain)
2004-11-12 11:14 EST, Gene Czarcinski
no flags Details
/etc/X11/xorg.conf for analog video (2.84 KB, text/plain)
2004-11-12 11:15 EST, Gene Czarcinski
no flags Details
startx messages for analog video (3.64 KB, text/plain)
2004-11-12 11:19 EST, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2004-11-12 11:11:11 EST
Description of problem:
Hardware:

ASUS SK8V with Opteron 140, 2GB RAM, ATI 9100, Dell 2000FP (lcd). 
Both the ATI 9100 and the Dell 2000FP support both analog and digital
video.  I need to use digital because with analog video the ASUS BIOS
screws up and overdrives the monitor although FC and X work just fine.

This problem occurs with both i386 and x86_64 installs.

This problem may be related to (be a dup of):
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=136108

Using digital video (DVI), the grphic install fails (nothing
displayed) although I can do everything install using text mode.

Once installed, I tried both DVI (digital) and analog video.  I am
attaching the /var/log/Xorg.0.log, /etc/X11/xorg.conf, and messages
captured from startx for the two cases (analog and digital).

Version-Release number of selected component (if applicable):
FC3

How reproducible:
everytime
Comment 1 Gene Czarcinski 2004-11-12 11:12:04 EST
Created attachment 106577 [details]
/var/log/Xorg.0.log for DVI
Comment 2 Gene Czarcinski 2004-11-12 11:12:41 EST
Created attachment 106578 [details]
/etc/X11/xorg.conf for DVI
Comment 3 Gene Czarcinski 2004-11-12 11:13:21 EST
Created attachment 106579 [details]
startx messages for DVI
Comment 4 Gene Czarcinski 2004-11-12 11:14:04 EST
Created attachment 106580 [details]
/var/log/Xorg.0.log for analog video
Comment 5 Gene Czarcinski 2004-11-12 11:15:23 EST
Created attachment 106581 [details]
/etc/X11/xorg.conf for analog video
Comment 6 Gene Czarcinski 2004-11-12 11:19:13 EST
Created attachment 106583 [details]
startx messages for analog video


NOTE: system-config-display recognizes the difference in the between when I
have the digital versus the analog video connected to the monitor.  When in
digital mode, I ran this from another system using ssh.
Comment 7 Chris Colohan 2004-11-14 21:40:00 EST
See also https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=138761
Comment 8 Mike A. Harris 2005-02-11 17:02:43 EST
Are you using a KVM switch, or any other cable in between the
video adaptor and monitor cable?
Comment 9 Gene Czarcinski 2005-02-12 17:41:34 EST
No.  The digital connection is direct.

Right now I am running an analog cable thru a KVM since this works
"better" than the digital.  This is a test system and I can run any
tests you would like.
Comment 10 Mike A. Harris 2005-02-16 16:47:45 EST
Does the problem occur if you remove the KVM switch and connect
the adaptor directly to the monitor, fully reboot, rerun
"system-config-display --reconfig", then start up X again?
Comment 11 Gene Czarcinski 2005-02-17 07:31:23 EST
I need some clarification as to just what you want.

1. As originally reported, the problem was with a DVI (digital)
directly connected 2000FB and did NOT involve any kvm.  The problem
also occured doing a graphical install.

2. Since installation, I have updated the system and it runs
xorg-x11-6.8.1.903-2 and systems-config-display-1.0.24-1 vice the
xorg-x11-6.8.1-12 and system-config-display-1.0.23-1.

Do you want me to run the test on the updated system?

Also, as I said, the failure occured with NO kvm.

Just what environment do you want me to test (other than no KVM which
is a given)?
Comment 12 Mike A. Harris 2005-04-11 04:26:32 EDT
Ok, this sounds like a generic problem with DVI panel detection in the
radeon driver.  There are a few reports in bugzilla of this nature
with different flat panels.  It seems to be Radeon 9200SE related usually,
but there are other cards seemingly affected as well.

Comment 13 Mike A. Harris 2005-04-11 04:42:01 EDT
Please file a bug report in X.Org bugzilla, which is located at
http://bugs.freedesktop.org in the "xorg" component.  This will ensure
maximal developer coverage and expose the issue to ATI developers as
well.

Once you've filed your report to X.Org, if you paste the URL here,
Red Hat will track the issue in X.Org bugzilla with upstream developers,
and will review any fixes that become available for potential inclusion
in future Fedora Core updates.
Comment 14 Mike A. Harris 2005-05-16 17:23:26 EDT
The current release of xorg-x11 for FC3 is 6.8.2.  There has not been any
feedback on this bug report since February 17, 2005 (3 months), and since
I've updated it with 2 comments since and have not heard back from anyone
who might have experienced this issue, and nobody has filed a bug upstream
in X.Org bugzilla and provided us with a URL to track the issue, I assume
it's fixed in the current update for Fedora Core 3, or Fedora Core 4 test3.

If the problem does still exist with all current FC3 updates applied, and
also exists in Fedora devel, file a bug report in X.Org bugzilla as requested
in comment #13 above and paste the URL here and Red Hat will track the issue
in X.Org bugzilla with upstream developers, and will review any fixes that
become available for potential inclusion in future Fedora Core updates.

Setting status to CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.