Bug 1390258 - rhn-migrate-classic-to-rhsm --keep --remove-rhn-packages should error out due to conflicting options
Summary: rhn-migrate-classic-to-rhsm --keep --remove-rhn-packages should error out due...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.9
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-31 15:04 UTC by John Sefler
Modified: 2017-03-21 10:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-21 10:56:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1517 'None' closed 1390258: Validate --remove-rhn-packages conflicting options 2020-02-11 13:31:08 UTC
Red Hat Product Errata RHSA-2017:0698 normal SHIPPED_LIVE Moderate: subscription-manager security, bug fix, and enhancement update 2017-03-21 12:39:12 UTC

Description John Sefler 2016-10-31 15:04:09 UTC
Description of problem:
When specifying the new --remove-rhn-packages option from RFE Bug 1185914 together with the --keep option, the tool should throw an EX_USAGE (exit code 64) error with a message like "The --remove-rhn-packages and --keep options cannot be used together."


Version-Release number of selected component (if applicable):
[root@jsefler-rhel6 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.18.3-1.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel6 ~]# rhn-migrate-classic-to-rhsm --remove-rhn-packages --keep
Destination username: testuser1
Destination password: 
Org: ^C
User interrupted process.
[root@jsefler-rhel6 ~]# 


Actual results:
above - notice that I aborted with Ctrl-C once the tool started promting me for credentials

Expected results:
[root@jsefler-rhel6 ~]# rhn-migrate-classic-to-rhsm --remove-rhn-packages --keep
The --remove-rhn-packages and --keep options cannot be used together.
[root@jsefler-rhel6 ~]# echo $?
64


Additional info:
See commit 270f2a3e5f7d55b69a6f98c160d38362961b3059 Bug 1217835 for a model example of throwing an EX_USAGE error due to conflicting rhn-migrate-classic-to-rhsmoptions.

Comment 3 Shwetha Kallesh 2016-11-28 07:19:08 UTC
The reproducer:

[root@dhcp35-179 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.18.4-1.el6
python-rhsm: 1.18.4-1.el6

[root@dhcp35-179 ~]#  rhn-migrate-classic-to-rhsm --remove-rhn-packages --keep
Destination username:



Verification:

[root@dhcp35-179 ~]# subscription-manager version
server type: RHN Classic
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.18.5-1.el6
python-rhsm: 1.18.5-1.el6


[root@dhcp35-179 ~]#  rhn-migrate-classic-to-rhsm --remove-rhn-packages --keep
The --remove-rhn-packages and --keep options cannot be used together.

Comment 5 errata-xmlrpc 2017-03-21 10:56:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2017-0698.html


Note You need to log in before you can comment on or make changes to this bug.