Bug 1390535 - semodule_package tries to mmap() an empty file
Summary: semodule_package tries to mmap() an empty file
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-01 10:27 UTC by Milos Malik
Modified: 2017-08-01 16:16 UTC (History)
7 users (show)

(edit)
Clone Of:
: 1390536 (view as bug list)
(edit)
Last Closed: 2017-08-01 16:16:12 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1883 normal SHIPPED_LIVE policycoreutils bug fix update 2017-08-01 17:53:54 UTC

Description Milos Malik 2016-11-01 10:27:47 UTC
Description of problem:
* already fixed in upstream, but it still affects RHEL-7.3

Version-Release number of selected component (if applicable):
policycoreutils-debuginfo-2.5-9.el7.x86_64
policycoreutils-sandbox-2.5-9.el7.x86_64
policycoreutils-python-2.5-9.el7.x86_64
policycoreutils-newrole-2.5-9.el7.x86_64
policycoreutils-devel-2.5-9.el7.x86_64
policycoreutils-gui-2.5-9.el7.x86_64
policycoreutils-2.5-9.el7.x86_64

How reproducible:
* always

Steps to Reproduce:
# checkmodule -M -m -o mypolicy.mod mypolicy.te
checkmodule:  loading policy configuration from mypolicy.te
checkmodule:  policy configuration loaded
checkmodule:  writing binary representation (version 17) to mypolicy.mod
# rm -f mypolicy.fc mypolicy.nc
# touch mypolicy.fc mypolicy.nc
# semodule_package -o mypolicy.pp -m mypolicy.mod --fc mypolicy.fc
semodule_package:  Failed to mmap mypolicy.fc:  Invalid argument
# semodule_package -o mypolicy.pp -m mypolicy.mod --nc mypolicy.nc
semodule_package:  Failed to mmap mypolicy.nc:  Invalid argument
# 

Actual results:
* semodule_package calls mmap() on an empty file

Expected results:
* semodule_package doesn't call mmap() on an empty file

Comment 1 Petr Lautrbach 2017-03-30 07:10:37 UTC
Probably fixed by this patch https://github.com/SELinuxProject/selinux/commit/266c16ff535a0d7fc89add6db3c13a879be6cdd5

Comment 5 errata-xmlrpc 2017-08-01 16:16:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1883


Note You need to log in before you can comment on or make changes to this bug.