Bug 1390716 - osd crashes when "radosgw-admin bi list --max-entries=1" command runing
Summary: osd crashes when "radosgw-admin bi list --max-entries=1" command runing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.1
Hardware: All
OS: All
unspecified
high
Target Milestone: rc
: 2.2
Assignee: Matt Benjamin (redhat)
QA Contact: shylesh
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1383917 1390717 1412948
TreeView+ depends on / blocked
 
Reported: 2016-11-01 17:47 UTC by Matt Benjamin (redhat)
Modified: 2017-07-30 15:53 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-10.2.5-22.el7cp Ubuntu: ceph_10.2.5-15redhat1xenial
Doc Type: Bug Fix
Doc Text:
.Listing bucket info data no longer causes the OSD daemon to terminate unexpectedly Due to invalid memory access in an object class operation, the `radosgw-admin bi list --max-entries=1` command in some cases caused the Ceph OSD daemon to terminate unexpectedly with a segmentation fault. This bug has been fixed, and listing bucket info data no longer causes the OSD daemon to crash.
Clone Of:
: 1390717 (view as bug list)
Environment:
Last Closed: 2017-03-14 15:46:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0514 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC
Ceph Project Bug Tracker 17745 None None None 2016-11-01 17:47:26 UTC

Description Matt Benjamin (redhat) 2016-11-01 17:47:26 UTC
Description of problem:
OSD can be induced to crash when given apparently correct argument for "bi list" RGW op


How reproducible:
100%


Steps to Reproduce:
1.radosgw-admin bi list --max-entries=1

Actual results:
1. OSD segfault


Expected results:
get 1-entry bucket index list segment, if applicable

Comment 8 Ken Dreyer (Red Hat) 2017-01-25 03:00:32 UTC
Matt, would you please cherry-pick https://github.com/ceph/ceph/pull/11758 downstream?

Comment 26 errata-xmlrpc 2017-03-14 15:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.