Bug 139076 - "Temperature above treshold".
"Temperature above treshold".
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-12 15:21 EST by Steven Van Impe
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-02 21:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steven Van Impe 2004-11-12 15:21:48 EST
This is a problem I've been having some some distros when I switched
to kernel 2.6. As soon as I start CPU intensive tasks, I get messages
from my kernel that my temperature is above treshold and that the cpu
will run in modulated clock mode. I'm not sure what causes these
messages, but they are quite annoying (show up al least every second
in my terminal). When I first had this (wasn't using Fedora yet), I
checked my BIOS, where the temperature read 70-80°C. Lm_sensors
however said the temperature was about 30°C (as I would expect it).
Also, the CPU's heatsink doesn't feel that warm, nowhere near 80°C.
This problem went away by itself, but now that I switched to Fedora,
it's back.

So is my BIOS causing this, or is it the kernel ?
I've tried updating the BIOS several times, but nothing changes.
Both my CPU and MB are Intel.
Comment 1 Aaron Sherman 2005-05-02 10:37:17 EDT
Let me get a bit deeper into this, as I'm seeing this too. I run FC3, and just
transitioned from 2.6.10 to 2.6.11 (both stock pre-built kernels) and
transitioned from regular to SMP kernel at the same time (for non-interesting
reasons, as I'm still running the same uniprocessor system).

When I did this, I started getting the errors spammed to every terminal, so I
checked the code. This alert is sent out as KERN.EMERG. It is NOT an emergency
notification, and should not be sent out as such. I understand why it would be
considered harmful to run hot, but those of us who choose to run a bit hotter
than spec wish to continue to find out systems (be they server or desktop) usable.

Lowering the level so that users are not tempted to shut of *.emerg reporting
would be wise.
Comment 2 Reaz 2005-05-16 23:09:58 EDT
i do have the problem on an MSI Neo3 main board

after i have upgrade the bios i do not have the problem.

the only thing is that it does not swithoff the motherboard,even if i add
acpi=off or acpi=ht in the grub.conf file.

any idea is the most wellcome 
Comment 3 Dave Jones 2005-07-15 14:56:19 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Dave Jones 2005-10-02 21:08:27 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.