Bug 139084 - matlab segfaults with glibc-2.3.3-27.1
matlab segfaults with glibc-2.3.3-27.1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 15:42 EST by john veysey
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-27 11:06:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john veysey 2004-11-12 15:42:39 EST
Description of problem:

Upgrading from glibc-2.3.3-27 (x86_64) to glibc-2.3.3-27.1 (x86_64)
breaks matlab (R7SP1) entirely, resulting segfaulting at launch:

MATLAB[5820]: segfault at 0000000000000018 rip 0000002a96c4163e rsp
0000007fbfffbb60 error 6

Version-Release number of selected component (if applicable):

2.3.3-27.1

How reproducible:
Always

Steps to Reproduce:
1. Run matlab 
2.
3.
  
Actual results:


Expected results:


Additional info:

The problem is fixed by returning to glibc-2.3.3-27
Comment 1 Jakub Jelinek 2004-11-15 12:15:57 EST
Can you
a) strace matlab, attach here strace -f output
b) ltrace matlab to see where it crashes
c) get a backtrace from gdb where it crashes?
Comment 2 Jakub Jelinek 2004-12-27 11:06:44 EST
Without that information we can hardly progress on this.

Note You need to log in before you can comment on or make changes to this bug.