Bug 139085 - oops in avc_has_perm when loading ati radeon R200 Microcode
Summary: oops in avc_has_perm when loading ati radeon R200 Microcode
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-12 20:50 UTC by Ryan Gammon
Modified: 2015-01-04 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-23 16:09:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardware (1.47 KB, text/plain)
2004-11-12 20:51 UTC, Ryan Gammon
no flags Details
oops (2.29 KB, text/plain)
2004-11-12 20:51 UTC, Ryan Gammon
no flags Details

Description Ryan Gammon 2004-11-12 20:50:00 UTC
Description of problem:
I see an oops in avc_has_perm_noaudit in my logs. When I installed
RHEL4beta2, my machine locked up when gdm first started. Not sure if
this was just the display, or the entire system... can retry and
provide more info on request.

On the second run, gdm started correctly, and I was able to use the
desktop. gconf didn't get configured correctly (probably due to the
lock up), and so I find myself getting a lot of gconf-related errors.

I had previously installed RHEL4beta1, and had not noticed this problem.

Version-Release number of selected component (if applicable):
2.6.9-1.648_EL

How reproducible:

Steps to Reproduce:
1. Install RHEL4beta2 on a system with hardware matching the attached
lspci output.
2. Note oops
3. Note lock-up on first gdm run.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ryan Gammon 2004-11-12 20:51:06 UTC
Created attachment 106602 [details]
hardware

Comment 2 Ryan Gammon 2004-11-12 20:51:39 UTC
Created attachment 106603 [details]
oops

Comment 4 Søren Sandmann Pedersen 2004-11-17 20:38:48 UTC
Could you try both the following:

   (a)  disable dri by commenting out the line "Load dri" in your
        /etc/X11/xorg.conf file

and, if that makes the problem go away,

   (b)  re-enable dri by uncommenting "load dri", and then 
        disabling Render acceleration by adding

            Option "RenderAccel" "False"

        to videocard section of /etc/X11/xorg.conf

It's not clear that this is even DRI related, but worth a shot. Thanks.



Comment 5 Mike A. Harris 2004-11-18 17:34:22 UTC
Also, with DRI enabled, try disabling SElinux to see if this is
SElinux specific problem.  You can do that by booting with
selinux=0 on the kernel commandline.

Comment 6 Ryan Gammon 2004-11-18 20:31:59 UTC
Mike, with selinux disabled from the installer everything seems to
work fine.

Soeren, I tried to do another SELinux-enabled install. The install
worked to the point where gdm came up with a login screen. At this
point, I switched to the console and tried to login. I got a kernel
panic on login:

Kernel panic - not syncing. Fatal exception in interrupt. Process
mingetty, stack pointer is garbage.

I think there might be two selinux-related bugs here:
1. Fatal kernel panic, somehow login related
2. Non-fatal oops, ati/X related

Both of these don't seem to happen in a non-SELinux install.

I don't have a functional RHEL4+SELinux install right now, will report
back what I find out regarding disabling dri when I do.

Comment 7 Suzanne Hillman 2005-03-22 21:37:30 UTC
Is this still a problem, or can it be closed?

Comment 8 Ryan Gammon 2005-03-22 21:55:37 UTC
It can be closed.


Note You need to log in before you can comment on or make changes to this bug.