Bug 139087 - umask set to 0002
umask set to 0002
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 15:53 EST by Steven Van Impe
Modified: 2014-03-16 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 16:07:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Van Impe 2004-11-12 15:53:59 EST
Why is this ?

At first I thought: hey, other users can write my files, but then I
noticed my user is in a separate group (username steven, uid 500,
groupname steven uid 500). Can anyone explain, since I've never seen
anything like this before and don't really see what is could be for ?

(Note: not sure I filed this for the right component, but I had to
take a guess).
Comment 1 Bill Nottingham 2004-11-12 16:07:43 EST
The default has always been one user per group. Google and the mailing
lists may be more helpful here.
Comment 2 Steven Van Impe 2004-11-12 16:24:24 EST
The only thing I could find so far was just 'red hat uses
one-user-groups by default', but I still don't understand why that is.
Doesn't this make the whole groups-thing useless ?

If there is an official explanation for this on the mailing lists
somewhere and someone has a direct link, that would be nice, since I'm
not too skilled at searching them (and this is the first time I've
ever used Red Hat of Fedora full-time).
Comment 3 Bill Nottingham 2004-11-12 16:33:05 EST
http://www.redhat.com/archives/redhat-list/2002-March/msg01753.html

has some information/discussion.
Comment 4 Alex Butcher 2004-11-19 20:03:38 EST
Also <http://www.google.com/search?q=user%20private%20group>
Comment 5 Steven Van Impe 2004-11-20 03:46:06 EST
Thanks for all the info :)

Note You need to log in before you can comment on or make changes to this bug.