Bug 1390871 - gDeploy: Ansible 1.9 version is pulled in as dependency for gdeploy on RHEL7
Summary: gDeploy: Ansible 1.9 version is pulled in as dependency for gdeploy on RHEL7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: RHGS 3.1.3 Async
Assignee: Sachidananda Urs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1351528
TreeView+ depends on / blocked
 
Reported: 2016-11-02 07:18 UTC by surabhi
Modified: 2017-03-07 17:46 UTC (History)
6 users (show)

Fixed In Version: gdeploy-2.0.1-3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 11:35:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0260 normal SHIPPED_LIVE Important: ansible and gdeploy security and bug fix update 2017-02-07 16:32:47 UTC

Description surabhi 2016-11-02 07:18:13 UTC
Description of problem:
******************************
With the install of latest gdeploy rpm , the ansible 1.9 is getting installed as a dependency rather than ansible 2.

Looks like the dependency for ansible2 version is not added in spec file.


Version-Release number of selected component (if applicable):
gdeploy-2.0.1-2.el7rhgs.noarch


How reproducible:
Always

Steps to Reproduce:
1.Install gdeploy on RHEL7
2.Check the ansible version getting installed
3.

Actual results:
Ansible 1.9 is getting installed as a dependency of gdeploy


Expected results:
Ansible 1.9 should not get installed as dependency rather ansible 2 shall be pulled in.


Additional info:

Comment 2 Sachidananda Urs 2016-11-02 07:22:37 UTC
This is merged into 3.2.0 branch.

Comment 5 SATHEESARAN 2016-11-09 15:24:54 UTC
I have verified the similar case with the bug - https://bugzilla.redhat.com/show_bug.cgi?id=1366306

Tested with gdeploy-2.0.1-3.el7rhgs installed on RHEL 7.3

gdeploy requires ansible-2.2 as dependency
host1 # rpm -qR gdeploy | grep ansible
ansible >= 2.2

On other hand, gdeploy for RHEL 6 doesn't has any requirement on ansible.

Comment 7 errata-xmlrpc 2017-02-07 11:35:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2017-0260.html


Note You need to log in before you can comment on or make changes to this bug.