Bug 1390876 - "--machine-readable" info should be updated in virt-v2v manual page
Summary: "--machine-readable" info should be updated in virt-v2v manual page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: V2V
Depends On: 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-02 07:39 UTC by kuwei@redhat.com
Modified: 2017-08-01 22:11 UTC (History)
6 users (show)

Fixed In Version: libguestfs-1.36.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:11:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description kuwei@redhat.com 2016-11-02 07:39:40 UTC
Description of problem:
"--machine-readable" info should be updated in virt-v2v manual page


Version-Release number of selected component (if applicable):
virt-v2v-1.32.7-3.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Run virt-v2v command with option "--machine-readable"
# virt-v2v  --machine-readable
virt-v2v
libguestfs-rewrite
colours-option
inputisk
input:libvirt
input:libvirtxml
input:ova
output:glance
output:libvirt
output:local
output:null
output:qemu
output:rhev
output:vdsm
convert:enterprise-linux
convert:windows


2:Then we check virt-v2v man page and there is no info “colours-option“ in --machine-readable option
# man virt-v2v
-------
MACHINE READABLE OUTPUT
       The --machine-readable option can be used to make the output more
       machine friendly, which is useful when calling virt-v2v from other
       programs, GUIs etc.

       There are two ways to use this option.

       Firstly use the option on its own to query the capabilities of the
       virt-v2v binary.  Typical output looks like this:

        $ virt-v2v --machine-readable
        virt-v2v
        libguestfs-rewrite
        inputisk
        [...]
        output:local
        [...]
        convert:enterprise-linux
        convert:windows

------


Actual results:
As description

Expected results:
"--machine-readable" should be added info "colours-option" in virt-v2v manual page

Additional info:

Comment 1 Pino Toscano 2016-11-02 08:39:58 UTC
Note the man page describes the option and the common elements in its output ("input:..", "output:..", and "convert:.."), and it might not list all the rest of the capabilities.

Fixing this bug is easy, but please do not expect that the man page describe (or even list) all the capabilities available.

Comment 2 mxie@redhat.com 2016-11-02 09:50:31 UTC
(In reply to Pino Toscano from comment #1)
> Note the man page describes the option and the common elements in its output
> ("input:..", "output:..", and "convert:.."), and it might not list all the
> rest of the capabilities.
> 
> Fixing this bug is easy, but please do not expect that the man page describe
> (or even list) all the capabilities available.

Hi Pino,

According to order of features listed in --machine-readable in v2v man page, --machine-readable seems like missing --colours-option,so we file this bug. v2v man page would be looking better if could fixing this,meanwhile,thanks for your suggestion.

Comment 3 Pino Toscano 2016-11-02 10:06:55 UTC
What I mean is that the man page provides the parts of output of --machine-readable as example of what it looks like. It does not list all of them, neither describes each element in detail, as the purpose of that documentation bit is to describe what --machine-readable is for.

Comment 4 Richard W.M. Jones 2016-11-02 10:10:17 UTC
Yup I don't believe this is a bug.  The manual page is just illustrative,
but to find out what the options mean you really need to check the code.

Comment 5 Pino Toscano 2016-11-02 16:21:11 UTC
Anyway, fixed with commit
https://github.com/libguestfs/libguestfs/commit/086be00aca450f94494b53234523d03e908b5d99
which is in libguestfs >= 1.35.15.

Comment 7 kuwei@redhat.com 2017-03-06 02:12:29 UTC
Test Versions:
libguestfs-1.36.1-1.el7.x86_64
virt-v2v-1.36.1-1.el7.x86_64


Test Steps:
The same as steps in Comment #0
#man virt-v2v
********
$ virt-v2v --machine-readable
        virt-v2v
        libguestfs-rewrite
        colours-option
        input:disk
        [...]
        output:local
        [...]
        convert:linux
        convert:windows
*********


Test Results:
"--machine-readable" had added info "colours-option" in virt-v2v manual page

So, the bug is fixed, change status to VERIFIED.

Comment 8 errata-xmlrpc 2017-08-01 22:11:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.